aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl/cross-generate_uudmap.patch
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-08 20:18:03 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-09 09:16:05 -0800
commitddb2be68c713361b1024b33080bf7c160337dbe1 (patch)
tree534a32ddcffcd3ea6a74480f102f13e5fef6777b /meta/recipes-devtools/perl/perl/cross-generate_uudmap.patch
parent0b25fcee333e6207a8596d26adfa65fec85c26df (diff)
downloadopenembedded-core-contrib-ddb2be68c713361b1024b33080bf7c160337dbe1.tar.gz
perl: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/perl/cross-generate_uudmap.patch')
-rw-r--r--meta/recipes-devtools/perl/perl/cross-generate_uudmap.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta/recipes-devtools/perl/perl/cross-generate_uudmap.patch b/meta/recipes-devtools/perl/perl/cross-generate_uudmap.patch
index a00ad61d90..33e222259f 100644
--- a/meta/recipes-devtools/perl/perl/cross-generate_uudmap.patch
+++ b/meta/recipes-devtools/perl/perl/cross-generate_uudmap.patch
@@ -1,15 +1,15 @@
Upstream-Status:Inappropriate [embedded specific]
-Index: perl-5.14.2/Makefile.SH
+Index: perl-5.24.1/Makefile.SH
===================================================================
---- perl-5.14.2.orig/Makefile.SH
-+++ perl-5.14.2/Makefile.SH
-@@ -622,7 +622,7 @@ bitcount.h: generate_uudmap$(HOST_EXE_EX
- $(RUN) ./generate_uudmap$(HOST_EXE_EXT) uudmap.h bitcount.h
+--- perl-5.24.1.orig/Makefile.SH
++++ perl-5.24.1/Makefile.SH
+@@ -710,7 +710,7 @@ bitcount.h: generate_uudmap\$(HOST_EXE_E
+ $spitshell >>$Makefile <<'!NO!SUBS!'
generate_uudmap$(HOST_EXE_EXT): generate_uudmap$(OBJ_EXT)
- $(CC) -o generate_uudmap$(EXE_EXT) $(LDFLAGS) generate_uudmap$(OBJ_EXT) $(libs)
+ $(BUILD_CC) -o generate_uudmap$(EXE_EXT) generate_uudmap.c
- miniperlmain$(OBJ_EXT): miniperlmain.c patchlevel.h
- $(CCCMD) $(PLDLFLAGS) $*.c
+ !NO!SUBS!
+ ;;