aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/libxml-simple-perl_2.25.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-03-23 01:37:55 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 09:54:49 +0100
commitd549289fa518a44274911d0959945196bbff930f (patch)
tree70c38ca802312692d29cb8ee9059fe1134765260 /meta/recipes-devtools/perl/libxml-simple-perl_2.25.bb
parentf98f0e6d8096290fdcc5fc6fc3b15638fa56158f (diff)
downloadopenembedded-core-contrib-d549289fa518a44274911d0959945196bbff930f.tar.gz
libxml-simple-perl: upgrade 2.24 -> 2.25
* Fix RDEPENDS Upstream release notes: 2.25 2018-03-18 16:18:24+13:00 Pacific/Auckland - disable entity expansion when using XML::Parser, for more secure default behaviour (patch from Ray Morris) - call to XML::Parser constructor is now in its own method to ease overriding License-Update: update year to 2018 Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/libxml-simple-perl_2.25.bb')
-rw-r--r--meta/recipes-devtools/perl/libxml-simple-perl_2.25.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libxml-simple-perl_2.25.bb b/meta/recipes-devtools/perl/libxml-simple-perl_2.25.bb
new file mode 100644
index 0000000000..53788d5585
--- /dev/null
+++ b/meta/recipes-devtools/perl/libxml-simple-perl_2.25.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Perl module for reading and writing XML"
+DESCRIPTION = "The XML::Simple Perl module provides a simple API layer \
+on top of an underlying XML parsing module to maintain XML files \
+(especially configuration files). It is a blunt rewrite of XML::Simple \
+(by Grant McLean) to use the XML::LibXML parser for XML structures, \
+where the original uses plain Perl or SAX parsers."
+HOMEPAGE = "http://search.cpan.org/~markov/XML-LibXML-Simple-0.93/lib/XML/LibXML/Simple.pod"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cf206df8c9fe775f1d4c484386491eac"
+DEPENDS += "libxml-parser-perl"
+
+SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Simple-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "bb841dce889a26c89a1c2739970e9fbc"
+SRC_URI[sha256sum] = "531fddaebea2416743eb5c4fdfab028f502123d9a220405a4100e68fc480dbf8"
+
+S = "${WORKDIR}/XML-Simple-${PV}"
+
+EXTRA_PERLFLAGS = "-I ${PERLHOSTLIB}"
+
+inherit cpan ptest-perl
+
+RDEPENDS_${PN} += " \
+ libxml-namespacesupport-perl \
+ libxml-parser-perl \
+ libxml-sax-perl \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ perl-module-file-temp \
+ perl-module-test-more \
+"
+
+BBCLASSEXTEND = "native"