summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/libmodule-build-perl_0.4229.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-01-08 14:27:59 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-10 20:32:04 +0000
commitdbbce0918617c21d0e43e9727d38372c22dff3dc (patch)
tree08d049ce111401aa8667a92dd678d7de2296e85d /meta/recipes-devtools/perl/libmodule-build-perl_0.4229.bb
parent829e8c49833e4cb8de5db869769eb492c827e8c9 (diff)
downloadopenembedded-core-contrib-dbbce0918617c21d0e43e9727d38372c22dff3dc.tar.gz
libmodule-build-perl: fix ptests
Particularly remove a broken detection of skipped tests (which was marking tests that actually passed), and install additional artefacts needed for testing. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/libmodule-build-perl_0.4229.bb')
-rw-r--r--meta/recipes-devtools/perl/libmodule-build-perl_0.4229.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libmodule-build-perl_0.4229.bb b/meta/recipes-devtools/perl/libmodule-build-perl_0.4229.bb
index f759f862fb..e3ba40d96c 100644
--- a/meta/recipes-devtools/perl/libmodule-build-perl_0.4229.bb
+++ b/meta/recipes-devtools/perl/libmodule-build-perl_0.4229.bb
@@ -36,7 +36,10 @@ do_patch[postfuncs] += "do_patch_module_build"
do_install_ptest() {
cp -r ${B}/inc ${D}${PTEST_PATH}
cp -r ${B}/blib ${D}${PTEST_PATH}
+ cp -r ${B}/_build ${D}${PTEST_PATH}
+ cp -r ${B}/lib ${D}${PTEST_PATH}
chown -R root:root ${D}${PTEST_PATH}
+ sed -i -e "s,'perl' => .*,'perl' => '/usr/bin/perl'\,,g" ${D}${PTEST_PATH}/_build/build_params
}
RDEPENDS_${PN} += " \