summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/files
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-12-22 09:26:07 -0800
committerSaul Wold <sgw@linux.intel.com>2011-01-12 00:55:48 -0800
commitf57e9daf74d5fbab6c9a3f5e60e1320a0bf0642d (patch)
treef6b24ea8f39fd6c83a161f91117641a851c4a9c6 /meta/recipes-devtools/perl/files
parentfde91acaf7849d80a2b9c908398bee2c3452004e (diff)
downloadopenembedded-core-contrib-f57e9daf74d5fbab6c9a3f5e60e1320a0bf0642d.tar.gz
perl, perl-native: upgrade from 5.8.8 to 5.12.2
Deleted these patches as they are part of the upstream code now. deleted: files/perl-5.8.8-gcc-4.2.patch deleted: perl-5.12.2/makedepend-dash.patch deleted: perl-5.12.2/native-no-gdbminc.patch deleted: perl-5.12.2/54_debian_perldoc-r.patch And rebased these patches to the newer source code modified: files/letgcc-find-errno.patch modified: perl-5.12.2/Makefile.patch modified: perl-5.12.2/asm-pageh-fix.patch modified: perl-5.12.2/native-nopacklist.patch modified: perl-5.12.2/native-perlinc.patch modified: perl-5.12.2/Makefile.SH.patch modified: perl-5.12.2/installperl.patch modified: perl-5.12.2/perl-dynloader.patch modified: perl-5.12.2/09_fix_installperl.patch get patches from debian perl ver 5.12.2-2 the fakeroot.diff patch from debian is conflicting with our Makefile.SH.patch, hence disabling the fakeroot patch use newly created config files Created with current milestone branch on qemu machines modified: config.sh modified: config.sh-32 modified: config.sh-64 get some changes from oe's perl 5.10.1 recipe fix the Makefile.SH.patch use miniperl instead of perl import a OE 5.10.1 patch: uudmap_cross fix install issues add /usr in the destdir, so that perl gets installed in /usr/bin/perl and not in /bin/perl link /usr/lib/perl to /usr/lib/perl5 so that operations with /usr/lib/perl path in them keep on working. Fix/Improve perl packaging avoid perl-module-module-* kind of packages recreate perl-rdepends_5.12.2.inc file with new set of packages import from oe perl-rprovide_5.12.2.inc combine all unicore perl scripts in one package simplify perl-lib reduce no of perl recipe packages greatly. Add zlib to depedancy fix buildtime host contamination This also fixes [BUGID #384] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/files')
-rw-r--r--meta/recipes-devtools/perl/files/letgcc-find-errno.patch14
-rw-r--r--meta/recipes-devtools/perl/files/perl-5.8.8-gcc-4.2.patch13
2 files changed, 8 insertions, 19 deletions
diff --git a/meta/recipes-devtools/perl/files/letgcc-find-errno.patch b/meta/recipes-devtools/perl/files/letgcc-find-errno.patch
index 24722ee964..47f972d039 100644
--- a/meta/recipes-devtools/perl/files/letgcc-find-errno.patch
+++ b/meta/recipes-devtools/perl/files/letgcc-find-errno.patch
@@ -8,10 +8,12 @@ external toolchain since perl will search in ${STAGING_INCDIR} for
errno.h (when using gcc) and that isn't where it's located - its
wherever the external toolchain keeps it's headers.
---- perl-5.8.8/ext/Errno/Errno_pm.PL 2007/04/30 14:10:10 1.1
-+++ perl-5.8.8/ext/Errno/Errno_pm.PL 2007/04/30 14:21:35
-@@ -11,8 +11,18 @@
- open OUT, ">Errno.pm" or die "Cannot open Errno.pm: $!";
+Index: perl-5.12.2/ext/Errno/Errno_pm.PL
+===================================================================
+--- perl-5.12.2.orig/ext/Errno/Errno_pm.PL
++++ perl-5.12.2/ext/Errno/Errno_pm.PL
+@@ -17,8 +17,18 @@ unlink "Errno.tmp" if -f "Errno.tmp";
+ open OUT, ">Errno.tmp" or die "Cannot open Errno.tmp: $!";
select OUT;
my $file;
-my @files = get_files();
@@ -31,12 +33,12 @@ wherever the external toolchain keeps it's headers.
# MinGW complains "warning: #pragma system_header ignored outside include
# file" if the header files are processed individually, so include them
# all in .c file and process that instead.
-@@ -44,7 +54,7 @@
+@@ -53,7 +63,7 @@ sub process_file {
chomp($file = `cygpath -w "$file"`);
}
- return unless defined $file and -f $file;
+# return unless defined $file and -f $file;
- # warn "Processing $file\n";
+ # warn "Processing $file\n";
local *FH;
diff --git a/meta/recipes-devtools/perl/files/perl-5.8.8-gcc-4.2.patch b/meta/recipes-devtools/perl/files/perl-5.8.8-gcc-4.2.patch
deleted file mode 100644
index 653a4758f4..0000000000
--- a/meta/recipes-devtools/perl/files/perl-5.8.8-gcc-4.2.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-See http://bugs.openembedded.net/show_bug.cgi?id=2168
-Fix for gcc 4.2
-
---- perl-5.8.8/makedepend.SH.ark 2006-11-01 16:32:05.000000000 +0100
-+++ perl-5.8.8/makedepend.SH 2006-11-01 16:32:15.000000000 +0100
-@@ -167,6 +167,7 @@
- -e '/^#.*<builtin>/d' \
- -e '/^#.*<built-in>/d' \
- -e '/^#.*<command line>/d' \
-+ -e '/^#.*<command-line>/d' \
- -e '/^#.*"-"/d' \
- -e '/: file path prefix .* never used$/d' \
- -e 's#\.[0-9][0-9]*\.c#'"$file.c#" \