aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl-sanity/files/fix-race-failures-2.patch
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2018-12-02 12:43:30 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-11 10:29:37 +0000
commit52f2828314f851263ca3a6beb41ec936fab4d3ab (patch)
tree69c6c3e1f5b69af6e59fc53f0f4cf9ee78dd0f0a /meta/recipes-devtools/perl-sanity/files/fix-race-failures-2.patch
parenta921a96e84f4d0b3f3d29a571981de08eb148e15 (diff)
downloadopenembedded-core-contrib-52f2828314f851263ca3a6beb41ec936fab4d3ab.tar.gz
perl: add a version that builds the recipe using perl-cross, and update to 5.28.1
perl-cross is a build system overlay from buildroot project that aims to bring a bit of sanity to cross-building perl. The advantage of using that is that we can drop a lot of custom patches (that no one really understands), and simplify the perl recipe as well. Also the build time goes down from several minutes to about 30 seconds. The whole thing becomes maintainable again, in my opinion. When rewriting the recipe I had two goals in mind: 1. Stay with upstream defaults as much as possible 2. Add custom patches only when their necessity was proven through testing. http://arsv.github.io/perl-cross/ Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/perl-sanity/files/fix-race-failures-2.patch')
-rw-r--r--meta/recipes-devtools/perl-sanity/files/fix-race-failures-2.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl-sanity/files/fix-race-failures-2.patch b/meta/recipes-devtools/perl-sanity/files/fix-race-failures-2.patch
new file mode 100644
index 0000000000..bc42342e14
--- /dev/null
+++ b/meta/recipes-devtools/perl-sanity/files/fix-race-failures-2.patch
@@ -0,0 +1,34 @@
+From e1e159a189247af1557fe400ca861714e5ed5af4 Mon Sep 17 00:00:00 2001
+From: Alex Suykov <alex.suykov@gmail.com>
+Date: Thu, 3 Jan 2019 22:03:20 +0200
+Subject: [PATCH] force crosspatch before any CC/HOSTCC rules
+
+Upstream-Status: Submitted [https://github.com/arsv/perl-cross/issues/72]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+
+---
+ Makefile | 10 +++++++---
+ 1 file changed, 7 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 01644cd..62bfc8c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -71,9 +71,13 @@ $(CROSSPATCHED): %.applied: %.patch
+ # (mostly Makefile.PLs, but others can be annoying too)
+ .SECONDARY:
+
+-# Force early building of miniperl -- not really necessary, but makes
+-# the build process more logical. No reason to try CC if HOSTCC fails.
+-all: crosspatch miniperl$X dynaloader perl$x nonxs_ext utilities extensions pods
++# Force full patching before any building starts. Als, force early building
++# of miniperl -- not really necessary, but makes the build process more logical.
++# No reason to try CC if HOSTCC fails.
++all:
++ $(MAKE) crosspatch
++ $(MAKE) miniperl$X
++ $(MAKE) dynaloader perl$x nonxs_ext utilities extensions pods
+
+ config.h: config.sh config_h.SH
+ CONFIG_H=$@ CONFIG_SH=$< ./config_h.SH
+