summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/patchelf
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-08-11 21:58:05 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-08-14 08:11:14 +0100
commit728775c87a7e35a03408675ce1c7a8cd061b2fda (patch)
treeb1b44e463f94fd8e217d8734d37bb91b9713f37c /meta/recipes-devtools/patchelf
parent0b2f8da3ff9cbbb6fc2ab75fbe09ad1fe745c53b (diff)
downloadopenembedded-core-contrib-728775c87a7e35a03408675ce1c7a8cd061b2fda.tar.gz
patchelf: replace a rejected patch with an equivalent uninative.bbclass tweak
This was the original reason to add the patch: https://git.openembedded.org/openembedded-core/commit/?id=18efcbcb896239c64fedd009ce57f3f0c668cbc0 and this is the upstream discussion which suggests handling read-only files explicitly outside of patchelf: https://github.com/NixOS/patchelf/pull/89 Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/patchelf')
-rw-r--r--meta/recipes-devtools/patchelf/patchelf/handle-read-only-files.patch63
-rw-r--r--meta/recipes-devtools/patchelf/patchelf_0.15.0.bb1
2 files changed, 0 insertions, 64 deletions
diff --git a/meta/recipes-devtools/patchelf/patchelf/handle-read-only-files.patch b/meta/recipes-devtools/patchelf/patchelf/handle-read-only-files.patch
deleted file mode 100644
index 76ad8d9d4d..0000000000
--- a/meta/recipes-devtools/patchelf/patchelf/handle-read-only-files.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 38b3d65f4a79d39ad9cdf841f2b3b29fd0c961ca Mon Sep 17 00:00:00 2001
-From: Fabio Berton <fabio.berton@ossystems.com.br>
-Date: Fri, 9 Sep 2016 16:00:42 -0300
-Subject: [PATCH] handle read-only files
-
-Patch from:
-https://github.com/darealshinji/patchelf/commit/40e66392bc4b96e9b4eda496827d26348a503509
-
-Upstream-Status: Denied [https://github.com/NixOS/patchelf/pull/89]
-
-Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
----
- src/patchelf.cc | 18 +++++++++++++-----
- 1 file changed, 13 insertions(+), 5 deletions(-)
-
-diff --git a/src/patchelf.cc b/src/patchelf.cc
-index 49accae..fb6c7ed 100644
---- a/src/patchelf.cc
-+++ b/src/patchelf.cc
-@@ -378,8 +378,16 @@ void ElfFile<ElfFileParamNames>::sortShdrs()
-
- static void writeFile(const std::string & fileName, const FileContents & contents)
- {
-+ struct stat st;
-+
- debug("writing %s\n", fileName.c_str());
-
-+ if (stat(fileName.c_str(), &st) != 0)
-+ error("stat");
-+
-+ if (chmod(fileName.c_str(), 0600) != 0)
-+ error("chmod");
-+
- int fd = open(fileName.c_str(), O_CREAT | O_TRUNC | O_WRONLY | O_BINARY, 0777);
- if (fd == -1)
- error("open");
-@@ -395,8 +403,6 @@ static void writeFile(const std::string & fileName, const FileContents & content
- bytesWritten += portion;
- }
-
-- if (close(fd) >= 0)
-- return;
- /*
- * Just ignore EINTR; a retry loop is the wrong thing to do.
- *
-@@ -405,9 +411,11 @@ static void writeFile(const std::string & fileName, const FileContents & content
- * http://utcc.utoronto.ca/~cks/space/blog/unix/CloseEINTR
- * https://sites.google.com/site/michaelsafyan/software-engineering/checkforeintrwheninvokingclosethinkagain
- */
-- if (errno == EINTR)
-- return;
-- error("close");
-+ if ((close(fd) < 0) && errno != EINTR)
-+ error("close");
-+
-+ if (chmod(fileName.c_str(), st.st_mode) != 0)
-+ error("chmod");
- }
-
-
---
-2.30.2
-
diff --git a/meta/recipes-devtools/patchelf/patchelf_0.15.0.bb b/meta/recipes-devtools/patchelf/patchelf_0.15.0.bb
index 389a0a9f40..e07775f574 100644
--- a/meta/recipes-devtools/patchelf/patchelf_0.15.0.bb
+++ b/meta/recipes-devtools/patchelf/patchelf_0.15.0.bb
@@ -5,7 +5,6 @@ HOMEPAGE = "https://github.com/NixOS/patchelf"
LICENSE = "GPL-3.0-only"
SRC_URI = "git://github.com/NixOS/patchelf;protocol=https;branch=master \
- file://handle-read-only-files.patch \
"
SRCREV = "49008002562355b0e35075cbc1c42c645ff04e28"