aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/orc/orc_0.4.28.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2017-12-05 13:51:45 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-18 18:00:22 +0000
commitdd59fb9755a02d6566c43b55c4a5bc541847f76e (patch)
treeeaf076fc063494723bc880ade76742381bdf946a /meta/recipes-devtools/orc/orc_0.4.28.bb
parentdc67acc061530b4b993a6f0ddd9bb9e34479eae9 (diff)
downloadopenembedded-core-contrib-dd59fb9755a02d6566c43b55c4a5bc541847f76e.tar.gz
orc: upgrade to 0.4.28
0.4.27 -> 0.4.28 Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/orc/orc_0.4.28.bb')
-rw-r--r--meta/recipes-devtools/orc/orc_0.4.28.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/orc/orc_0.4.28.bb b/meta/recipes-devtools/orc/orc_0.4.28.bb
new file mode 100644
index 0000000000..415de64dc4
--- /dev/null
+++ b/meta/recipes-devtools/orc/orc_0.4.28.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Optimised Inner Loop Runtime Compiler"
+HOMEPAGE = "http://gstreamer.freedesktop.org/modules/orc.html"
+LICENSE = "BSD-2-Clause & BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1400bd9d09e8af56b9ec982b3d85797e"
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/orc/orc-${PV}.tar.xz"
+
+SRC_URI[md5sum] = "6b582ec4b3275c5efd51e3ae6406d445"
+SRC_URI[sha256sum] = "bfcd7c6563b05672386c4eedfc4c0d4a0a12b4b4775b74ec6deb88fc2bcd83ce"
+
+inherit autotools pkgconfig gtk-doc
+
+BBCLASSEXTEND = "native nativesdk"
+
+PACKAGES =+ "orc-examples"
+PACKAGES_DYNAMIC += "^liborc-.*"
+FILES_orc-examples = "${libdir}/orc/*"
+FILES_${PN} = "${bindir}/*"
+
+python populate_packages_prepend () {
+ libdir = d.expand('${libdir}')
+ do_split_packages(d, libdir, '^lib(.*)\.so\.*', 'lib%s', 'ORC %s library', extra_depends='', allow_links=True)
+}
+
+do_compile_prepend_class-native () {
+ sed -i -e 's#/tmp#.#g' ${S}/orc/orccodemem.c
+}