aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/orc/orc_0.4.23.bb
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2015-01-26 06:46:36 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-29 10:37:51 +0000
commitcca0ccfa9d019131f0c206f46d4f6af3e1eb2cf7 (patch)
treeea45f0324cd80de356d6e33ee1338f007c6ac5f6 /meta/recipes-devtools/orc/orc_0.4.23.bb
parentcc95da21914d08bfbf1936830985f824e8813904 (diff)
downloadopenembedded-core-contrib-cca0ccfa9d019131f0c206f46d4f6af3e1eb2cf7.tar.gz
orc : Update to 0.4.23.
Orc has moved to freedesktop.org, so the fetch URL changed. Dropped the .inc file and PR from the recipe. This version fixes a bug that led to problems on armhf abi builds. https://bugzilla.gnome.org/show_bug.cgi?id=727464 Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/orc/orc_0.4.23.bb')
-rw-r--r--meta/recipes-devtools/orc/orc_0.4.23.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/orc/orc_0.4.23.bb b/meta/recipes-devtools/orc/orc_0.4.23.bb
new file mode 100644
index 0000000000..0e07731ac6
--- /dev/null
+++ b/meta/recipes-devtools/orc/orc_0.4.23.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Optimised Inner Loop Runtime Compiler"
+HOMEPAGE = "http://code.entropywave.com/projects/orc/"
+LICENSE = "BSD-2-Clause & BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1400bd9d09e8af56b9ec982b3d85797e"
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/orc/orc-${PV}.tar.xz;name=orc"
+SRC_URI[orc.md5sum] = "72e0612ace54d77aa2f7a006348ee81a"
+SRC_URI[orc.sha256sum] = "767eaebce2941737b43368225ec54598b3055ca78b4dc50c4092f5fcdc0bdfe7"
+
+inherit autotools pkgconfig
+
+BBCLASSEXTEND = "native nativesdk"
+
+PACKAGES =+ "orc-examples"
+FILES_orc-examples = "${libdir}/orc/*"
+FILES_${PN} = "${bindir}/*"
+
+python populate_packages_prepend () {
+ libdir = d.expand('${libdir}')
+ do_split_packages(d, libdir, '^lib(.*)\.so\.*', 'lib%s', 'ORC %s library', extra_depends='', allow_links=True)
+}
+
+do_compile_prepend_virtclass-native () {
+ sed -i -e 's#/tmp#.#g' ${S}/orc/orccodemem.c
+}