aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg
diff options
context:
space:
mode:
authorPaul Barker <paul@paulbarker.me.uk>2013-06-17 01:22:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-17 17:02:47 +0100
commit873689bbabba25e7be5c12317c04519a7bc8d0ef (patch)
treed72072916f8493e9e688d10902f0b40a645d7693 /meta/recipes-devtools/opkg/opkg
parent631a0ec8cc7e53c2df2fc62c5276f940ed45b39e (diff)
downloadopenembedded-core-contrib-873689bbabba25e7be5c12317c04519a7bc8d0ef.tar.gz
opkg: fix header installation for libopkg
When opkg is built outside the source directory, libopkg headers aren't all installed as the search path for headers only includes the directory that make is being ran in, not the source directory. So we fix this by adding $(srcdir)/*.h to the list of header files to install. Without this patch, "/usr/include/libopkg" will only include the file config.h. With this patch, other files such as "opkg.h" are present which are needed to compile software which uses libopkg. The new patch has also been submitted upstream as a fix to opkg itself. Signed-off-by: Paul Barker <paul@paulbarker.me.uk> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg')
-rw-r--r--meta/recipes-devtools/opkg/opkg/0001-Fix-libopkg-header-installation.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg/0001-Fix-libopkg-header-installation.patch b/meta/recipes-devtools/opkg/opkg/0001-Fix-libopkg-header-installation.patch
new file mode 100644
index 0000000000..c27fdb13b4
--- /dev/null
+++ b/meta/recipes-devtools/opkg/opkg/0001-Fix-libopkg-header-installation.patch
@@ -0,0 +1,32 @@
+From 79a40cc4c3b5d6f8a90d9dc0ac5d2c40983764f7 Mon Sep 17 00:00:00 2001
+From: Paul Barker <paul@paulbarker.me.uk>
+Date: Sun, 16 Jun 2013 23:27:27 +0100
+Subject: [PATCH] Fix libopkg header installation.
+
+When opkg is built outside the source directory, libopkg headers aren't all
+installed as the search path for headers only includes the directory that make
+is being ran in, not the source directory. So we fix this by adding
+$(srcdir)/*.h to the list of header files to install.
+
+Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
+Upstream-status: Submitted
+---
+ libopkg/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libopkg/Makefile.am b/libopkg/Makefile.am
+index 043c5c4..b6f4f7b 100644
+--- a/libopkg/Makefile.am
++++ b/libopkg/Makefile.am
+@@ -2,7 +2,7 @@
+ AM_CFLAGS=-Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DOPKGETCDIR=\"@opkgetcdir@\" -DOPKGLOCKFILE=\"@opkglockfile@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS) $(PATHFINDER_CFLAGS)
+
+ libopkg_includedir=$(includedir)/libopkg
+-libopkg_include_HEADERS= *.h
++libopkg_include_HEADERS= *.h $(srcdir)/*.h
+
+
+ opkg_libcore_sources = \
+--
+1.8.3
+