summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg/0001-opkg-add-target-for-testsuite-installation.patch
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2019-04-10 15:54:23 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-11 21:19:27 +0100
commit6b9963a58eec9f5f5fe72021d13e3c89461a9649 (patch)
treecd059c2ee28daf2a8e20b99f77dd5e8137a1cf16 /meta/recipes-devtools/opkg/opkg/0001-opkg-add-target-for-testsuite-installation.patch
parent2c6fff3fe315357d65d082679856615afc367d90 (diff)
downloadopenembedded-core-contrib-6b9963a58eec9f5f5fe72021d13e3c89461a9649.tar.gz
opkg: add ptest
Install opkg test suite and run it as ptest. Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg/0001-opkg-add-target-for-testsuite-installation.patch')
-rw-r--r--meta/recipes-devtools/opkg/opkg/0001-opkg-add-target-for-testsuite-installation.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg/0001-opkg-add-target-for-testsuite-installation.patch b/meta/recipes-devtools/opkg/opkg/0001-opkg-add-target-for-testsuite-installation.patch
new file mode 100644
index 0000000000..951c186767
--- /dev/null
+++ b/meta/recipes-devtools/opkg/opkg/0001-opkg-add-target-for-testsuite-installation.patch
@@ -0,0 +1,43 @@
+From 8fb0364bd0e19f35c20616dd1ab10aa00e08fa8f Mon Sep 17 00:00:00 2001
+From: Alejandro del Castillo <alejandro.delcastillo@ni.com>
+Date: Wed, 10 Apr 2019 14:49:43 -0500
+Subject: [PATCH] opkg: add target for testsuite installation
+
+- Add target to install testsuite
+- Add override of opkg binary used during test via OPKG_PATH environment
+variable.
+
+Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com>
+---
+Upstream-Status: Submitted
+
+ Makefile.am | 5 +++++
+ tests/cfg.py | 2 +-
+ 2 files changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 90cfcae..1f6a784 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -18,3 +18,8 @@ run-tests:
+ $(MAKE) -C tests DATADIR=@datadir@ SYSCONFDIR=@sysconfdir@ VARDIR=@localstatedir@
+
+ check: run-tests
++
++install-ptest:
++ cp -r $(srcdir)/tests $(DESTDIR)
++ cp Makefile $(DESTDIR)
++ sed -e 's/^Makefile/_Makefile/' < Makefile > $(DESTDIR)/Makefile
+diff --git a/tests/cfg.py b/tests/cfg.py
+index 4efaff6..ca59d03 100644
+--- a/tests/cfg.py
++++ b/tests/cfg.py
+@@ -2,4 +2,4 @@ import os
+
+ opkdir = "/tmp/opk"
+ offline_root = "/tmp/opkg"
+-opkgcl = os.path.realpath("../src/opkg")
++opkgcl = os.getenv('OPKG_PATH', os.path.realpath("../src/opkg"))
+--
+2.20.1
+