aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg-collateral.bb
diff options
context:
space:
mode:
authorPaul Barker <paul@paulbarker.me.uk>2014-12-19 17:35:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-03 14:53:44 +0000
commitf7c591df37493e8f3cde9c19bb0d1edc370eca1c (patch)
tree8e5f0367e1195186e5b78603662dd348bdede626 /meta/recipes-devtools/opkg/opkg-collateral.bb
parentd0cb4fb3aab1d6041f88fa564e5d745629316ae2 (diff)
downloadopenembedded-core-contrib-f7c591df37493e8f3cde9c19bb0d1edc370eca1c.tar.gz
opkg-collateral: Simplify source files
Instead of having the source files 'opkg.conf.comments', 'dest' and 'src', we simply have one 'opkg.conf' file containing all the necessary configuration. This does mean that replacing 'src' in a bbappend to define distro-specific package feeds is no longer supported, but these feed configurations should be packaged separately from the rest of the opkg configuration anyway so that things can be updated independently. The best recipe to use for managing feed configs is currently distro-feed-config in the meta-oe layer. Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg-collateral.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg-collateral.bb7
1 files changed, 1 insertions, 6 deletions
diff --git a/meta/recipes-devtools/opkg/opkg-collateral.bb b/meta/recipes-devtools/opkg/opkg-collateral.bb
index 0cf6b8be40..f080dfc3ab 100644
--- a/meta/recipes-devtools/opkg/opkg-collateral.bb
+++ b/meta/recipes-devtools/opkg/opkg-collateral.bb
@@ -4,17 +4,12 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
PR = "r2"
-SRC_URI = "file://opkg.conf.comments \
- file://dest \
- file://src "
+SRC_URI = "file://opkg.conf"
S = "${WORKDIR}"
OPKGLIBDIR = "${localstatedir}/lib"
do_compile () {
- cat ${WORKDIR}/opkg.conf.comments >${WORKDIR}/opkg.conf
- cat ${WORKDIR}/src >>${WORKDIR}/opkg.conf
- cat ${WORKDIR}/dest >>${WORKDIR}/opkg.conf
echo "option lists_dir ${OPKGLIBDIR}/opkg" >>${WORKDIR}/opkg.conf
}