aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg-collateral.bb
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2013-02-04 23:06:52 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-06 09:35:01 +0000
commitcf0aa9c4fdae8855803e96b1922d54a2431795d3 (patch)
treee3e5cfed064f7243885c8e8a57779dbfa5a287b7 /meta/recipes-devtools/opkg/opkg-collateral.bb
parent8abcf2c3541d7fe96d7717cb161812784dca6c66 (diff)
downloadopenembedded-core-contrib-cf0aa9c4fdae8855803e96b1922d54a2431795d3.tar.gz
ipk: use OPKGLIBDIR in all places
* it's not recommended to change this value, because it breaks upgrade path on target (all old u-a alternatives are forgot in old OPKGLIBDIR value * but make it consistent, so if someone really want to change that, then setting OPKGLIBDIR_distro in distro.conf would be enough * without this there were at least 4 places to change: rootfs_ipk: opkglibdir variable (notice that I've removed /opkg from it to correspond with EXTRA_OECONF option used in opkg recipes package_ipk: ${target_rootfs}${localstatedir}/lib/opkg/ hardcoded in package_install_internal_ipk opkg-collateral: value in lists file opkg: EXTRA_OECONF for all 3 classes, FILES_libopkg, do_install * validated with buildhistory that without OPKGLIBDIR explicitly set the output is the same and that after setting OPKGLIBDIR_forcevariable := "${libdir}" everything including empty directory from package_ipk is moved to libdir Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg-collateral.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg-collateral.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/opkg/opkg-collateral.bb b/meta/recipes-devtools/opkg/opkg-collateral.bb
index 251c535438..cacd8800e9 100644
--- a/meta/recipes-devtools/opkg/opkg-collateral.bb
+++ b/meta/recipes-devtools/opkg/opkg-collateral.bb
@@ -2,18 +2,18 @@ DESCRIPTION = "opkg configuration files"
SECTION = "base"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r1"
+PR = "r2"
SRC_URI = "file://opkg.conf.comments \
- file://lists \
file://dest \
file://src "
+OPKGLIBDIR = "${localstatedir}/lib"
do_compile () {
cat ${WORKDIR}/opkg.conf.comments >${WORKDIR}/opkg.conf
cat ${WORKDIR}/src >>${WORKDIR}/opkg.conf
cat ${WORKDIR}/dest >>${WORKDIR}/opkg.conf
- cat ${WORKDIR}/lists >>${WORKDIR}/opkg.conf
+ echo "lists_dir ext ${OPKGLIBDIR}/opkg" >>${WORKDIR}/opkg.conf
}
do_install () {