aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg-utils
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-06-08 13:57:31 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-12 15:04:08 +0100
commit25c8d738b904c8755df203122067afa0047b27ad (patch)
tree6253efa4e662560342d659ed2243bf8854eece60 /meta/recipes-devtools/opkg-utils
parenta58e53f55259acd79a98a0f8b8a435d2a5aef36e (diff)
downloadopenembedded-core-contrib-25c8d738b904c8755df203122067afa0047b27ad.tar.gz
opkg-utils: if Python support is disabled, delete the Python scripts
To make it obvious what is lost when python is disabled, actually delete the scripts so the user can't attempt to use them. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/opkg-utils')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
index 06710b596b..ed5980b858 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
@@ -19,6 +19,7 @@ S = "${WORKDIR}/git"
TARGET_CC_ARCH += "${LDFLAGS}"
+# For native builds we use the host Python
PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-subprocess python3-pickle python3-compression python3-textutils python3-stringold"
PYTHONRDEPS_class-native = ""
@@ -31,6 +32,10 @@ do_install() {
if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then
rm -f "${D}${bindir}/update-alternatives"
fi
+
+ if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then
+ grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm
+ fi
}
do_install_append_class-target() {