aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg-utils
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2011-08-26 17:49:25 +0400
committerSaul Wold <sgw@linux.intel.com>2011-08-26 12:34:03 -0700
commitf55c96b6d53ecff865145fa22f286c89c7336515 (patch)
tree4aa36e2b1faaf30f387470067b454d460d548746 /meta/recipes-devtools/opkg-utils
parentfeaf1bab56138cc1bc998a4201a60202a5b8cd28 (diff)
downloadopenembedded-core-contrib-f55c96b6d53ecff865145fa22f286c89c7336515.tar.gz
opkg-utils: ignore packages disapperaring filelist generation
Package files disappearing during index generation don't cause a fatal error. Make package file disappearing during filelist generation also a non-fatal error. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/opkg-utils')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils/index-ignore-filenotfound.patch17
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb2
2 files changed, 18 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils/index-ignore-filenotfound.patch b/meta/recipes-devtools/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
index 3664df6635..f0f0fcf12c 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
@@ -54,3 +54,20 @@ Index: opkg-utils/opkg-make-index
if packages_filename:
sys.stdout.close()
sys.stdout = old_stdout
+@@ -197,7 +197,15 @@
+ names = packages.packages.keys()
+ names.sort()
+ for name in names:
+- for fn in packages[name].get_file_list():
++ try:
++ fnlist = packages[name].get_file_list()
++ except OSError, e:
++ sys.stderr.write("Package %s disappeared on us!\n" % (name))
++ continue
++ except IOError, e:
++ sys.stderr.write("Package %s disappeared on us!\n" % (name))
++ continue
++ for fn in fnlist:
+ (h,t) = os.path.split(fn)
+ if not t: continue
+ if not files.has_key(t): files[t] = name+':'+fn
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb
index fd2b5e693d..e04b74ace5 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb
@@ -8,7 +8,7 @@ RDEPENDS_${PN} = "python"
RDEPENDS_${PN}_virtclass-native = ""
SRCREV = "4747"
PV = "0.1.8+svnr${SRCPV}"
-PR = "r4"
+PR = "r5"
SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \
file://index-ignore-filenotfound.patch \