aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg-utils
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-05-19 13:56:00 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-20 12:36:53 +0100
commitd85c4cb45159bbc1da138def38acd0134b9d0c4c (patch)
tree1ec64f96206e64033c70f4a1f52cb82a54c9aa48 /meta/recipes-devtools/opkg-utils
parent01e34bdb43e0cc27c1cfffd6730c384f40c404c1 (diff)
downloadopenembedded-core-contrib-d85c4cb45159bbc1da138def38acd0134b9d0c4c.tar.gz
opkg-utils: Synchronise with OE
Import mtime-int.patch from OE commit c81990aecae3bdf70a7c924699776b248ab7a006 Pass LDFLAGS to linker to avoid missing GNU_HASH QA errors Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/opkg-utils')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils/mtime-int.patch29
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb7
2 files changed, 34 insertions, 2 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils/mtime-int.patch b/meta/recipes-devtools/opkg-utils/opkg-utils/mtime-int.patch
new file mode 100644
index 0000000000..fdbce21e4e
--- /dev/null
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils/mtime-int.patch
@@ -0,0 +1,29 @@
+Convert mtime to int before comparing it
+
+The st_mtime attribute (which is a float) is compared against a value
+from the timestamp database, which was stored as an integer there.
+
+When working on a filesystem with precise timestamps the comparision
+will fail nearly everytime hence.
+
+Although it might be possible to enhance the database to store the
+fractional part too, this will complicate things more than we would
+gain by this change.
+
+Signed-off-by: Enrico Scholz <enrico.scholz@sigma-chemnitz.de>
+
+Upstream-Status: Pending
+
+Index: opkg-utils/opkg-make-index
+===================================================================
+--- opkg-utils.orig/opkg-make-index
++++ opkg-utils/opkg-make-index
+@@ -100,7 +100,7 @@ for filename in files:
+ pkg = None
+ fnameStat = os.stat(filename)
+ if old_pkg_hash.has_key(basename):
+- if pkgsStamps.has_key(basename) and fnameStat.st_mtime == pkgsStamps[basename]:
++ if pkgsStamps.has_key(basename) and int(fnameStat.st_mtime) == pkgsStamps[basename]:
+ if (verbose):
+ sys.stderr.write("Found %s in Packages\n" % (filename,))
+ pkg = old_pkg_hash[basename]
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb
index 0db6f802f3..79cee2e4f5 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb
@@ -9,10 +9,12 @@ RDEPENDS_${PN} = "python"
RDEPENDS_${PN}_virtclass-native = ""
SRCREV = "4747"
PV = "0.1.8+svnr${SRCPV}"
-PR = "r2"
+PR = "r3"
SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \
- file://index-ignore-filenotfound.patch"
+ file://index-ignore-filenotfound.patch \
+ file://mtime-int.patch \
+ "
S = "${WORKDIR}/opkg-utils"
@@ -24,3 +26,4 @@ do_install() {
}
BBCLASSEXTEND = "native"
+TARGET_CC_ARCH += "${LDFLAGS}"