aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg-utils
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-26 10:47:29 +0100
committerSaul Wold <sgw@linux.intel.com>2011-11-29 00:20:06 -0800
commit529d45a3daaeb60ecee8b15778c3b70d7992cd1f (patch)
tree73cdebb711fd1bcbd12fd5a6a981d0ae85d41c38 /meta/recipes-devtools/opkg-utils
parent9b13b9024d24953dedb35f62d3d8b06a29036992 (diff)
downloadopenembedded-core-contrib-529d45a3daaeb60ecee8b15778c3b70d7992cd1f.tar.gz
opkg-utils: handle 6 digit UID fields properly
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta/recipes-devtools/opkg-utils')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils/arfile_header_split.patch27
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb3
2 files changed, 29 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils/arfile_header_split.patch b/meta/recipes-devtools/opkg-utils/opkg-utils/arfile_header_split.patch
new file mode 100644
index 0000000000..435e74e863
--- /dev/null
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils/arfile_header_split.patch
@@ -0,0 +1,27 @@
+From: Scott Anderson <o2e@saaworld.com>
+Subject: ipkg-utils: Make arfile.py handle six digit UIDs
+
+ Essentially, the problem is that arfile.py is splitting the ar header with
+ white-space instead of fixed-width fields, so two fields would get treated
+ as a single field. This makes things better than before as it now honors
+ the fixed field widths.
+
+Upsteam-status: Pending (there is no upstream after openmoko imploded)
+
+--- ipkg-utils/arfile.py.orig 2010-09-29 13:38:15.000000000 -0700
++++ ipkg-utils/arfile.py 2010-10-01 16:06:00.000000000 -0700
+@@ -74,7 +74,12 @@
+ if l == "\n":
+ l = self.f.readline()
+ if not l: break
+ l = l.replace('`', '')
+- descriptor = l.split()
++ # Field lengths from /usr/include/ar.h:
++ ar_field_lens = [ 16, 12, 6, 6, 8, 10, 2 ]
++ descriptor = []
++ for field_len in ar_field_lens:
++ descriptor.append(l[:field_len].strip())
++ l = l[field_len:]
+ # print descriptor
+ size = int(descriptor[5])
+ memberName = descriptor[0][:-1]
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb
index e04b74ace5..9b94aff023 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb
@@ -8,12 +8,13 @@ RDEPENDS_${PN} = "python"
RDEPENDS_${PN}_virtclass-native = ""
SRCREV = "4747"
PV = "0.1.8+svnr${SRCPV}"
-PR = "r5"
+PR = "r6"
SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \
file://index-ignore-filenotfound.patch \
file://mtime-int.patch \
file://add-license-field.patch \
+ file://arfile_header_split.patch \
"
S = "${WORKDIR}/opkg-utils"