aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.14.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-17 17:19:41 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-19 17:03:16 +0000
commitac9b892f06237a384a60d0404e6ed0afd63c1005 (patch)
tree112fbea588c90cebeaad6f2230b873e19c9ed3f6 /meta/recipes-devtools/nasm/nasm_2.14.bb
parent2c858a2e1c8c99f87e74c2f95ccc749edfbe01ac (diff)
downloadopenembedded-core-contrib-ac9b892f06237a384a60d0404e6ed0afd63c1005.tar.gz
nasm: Upgrade 2.13.03 -> 2.14
The patches are all backports or have equivalent changes in the new release so can be dropped. Upstream reworked the install handling to use DESTDIR instead of INSTALLROOT and we no longer need to create directories. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.14.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.14.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.14.bb b/meta/recipes-devtools/nasm/nasm_2.14.bb
new file mode 100644
index 0000000000..231d4e6b15
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.14.bb
@@ -0,0 +1,25 @@
+SUMMARY = "General-purpose x86 assembler"
+SECTION = "devel"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
+
+SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "238a240d3f869a52f8ac38ee3f8faafa"
+SRC_URI[sha256sum] = "d43cfd27cad53d0c22a9bf9702e9dffcc7018a0df21d15b92c56d250d747c744"
+
+inherit autotools-brokensep
+
+do_configure_prepend () {
+ if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then
+ mv ${S}/aclocal.m4 ${S}/acinclude.m4
+ fi
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+BBCLASSEXTEND = "native"
+
+DEPENDS = "groff-native"