aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.10.06.bb
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2012-12-21 15:02:20 +0200
committerSaul Wold <sgw@linux.intel.com>2012-12-25 14:00:22 -0800
commitaf62834005bfc96fac57aaca5d455064f8ba45f6 (patch)
treec6030ca1d3ae3d901b7e6c325cab793fb884db6d /meta/recipes-devtools/nasm/nasm_2.10.06.bb
parenta9d25a8e6720ceff5cfefa3191026357dd6e0f49 (diff)
downloadopenembedded-core-contrib-af62834005bfc96fac57aaca5d455064f8ba45f6.tar.gz
nasm: upgraded to 2.10.06
Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.10.06.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.10.06.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.10.06.bb b/meta/recipes-devtools/nasm/nasm_2.10.06.bb
new file mode 100644
index 0000000000..cb12a22dc0
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.10.06.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "General-purpose x86 assembler"
+SECTION = "devel"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
+COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
+
+PR = "r0"
+
+SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
+SRC_URI[md5sum] = "875c4217b2e581dbae0bf96d45a6067a"
+SRC_URI[sha256sum] = "ac84dd0d7e4ad6282061ce36b68a72db591db55cf0902b53d4297c743b0944a6"
+
+inherit autotools
+
+do_configure_prepend () {
+ if [ -f aclocal.m4 ] && [ ! -f acinclude.m4 ]; then
+ mv aclocal.m4 acinclude.m4
+ fi
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man1
+
+ oe_runmake 'INSTALLROOT=${D}' install
+}
+
+BBCLASSEXTEND = "native"
+
+DEPENDS = "groff-native"