summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.10.05.bb
diff options
context:
space:
mode:
authorConstantin Musca <constantinx.musca@intel.com>2012-12-05 12:40:19 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 12:30:37 +0000
commiteebd134989b32577cb1e59897de25c320e61f03c (patch)
treeb62f0815864169edb7f6ffbaf49c692afa081b9a /meta/recipes-devtools/nasm/nasm_2.10.05.bb
parent3c93065cfb53edea920469c8bdfde1dcbf61ff2e (diff)
downloadopenembedded-core-contrib-eebd134989b32577cb1e59897de25c320e61f03c.tar.gz
nasm: upgrade to 2.10.05
Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.10.05.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.10.05.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.10.05.bb b/meta/recipes-devtools/nasm/nasm_2.10.05.bb
new file mode 100644
index 0000000000..d430b1e4da
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.10.05.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "General-purpose x86 assembler"
+SECTION = "devel"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
+COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
+
+PR = "r0"
+
+SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
+SRC_URI[md5sum] = "d3c50875fd923b782749f883294336ed"
+SRC_URI[sha256sum] = "de5af263ce344d3a89711c61802e3ad8a4e14a61d539f521f7554cdbbe04ed0f"
+
+inherit autotools
+
+do_configure_prepend () {
+ if [ -f aclocal.m4 ] && [ ! -f acinclude.m4 ]; then
+ mv aclocal.m4 acinclude.m4
+ fi
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man1
+
+ oe_runmake 'INSTALLROOT=${D}' install
+}
+
+BBCLASSEXTEND = "native"
+
+DEPENDS = "groff-native"