summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/mtd
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-03-04 17:31:42 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-04 22:57:05 +0000
commit062bab22d73e7e968e5c129d2fcea65f74e49084 (patch)
tree318ff038c286da36b1f8f4f24715881505e966bf /meta/recipes-devtools/mtd
parent4d994fe150c368b63070801642b5b1940f5b44fa (diff)
downloadopenembedded-core-contrib-062bab22d73e7e968e5c129d2fcea65f74e49084.tar.gz
mtd-utils: add lzo PACKAGECONFIG
LZO support is optional so add a PACKAGECONFIG to control this. Also clean up the xattr PACKAGECONFIG to explicitly enable/disable. (From OE-Core rev: 69a4dd839b0659c1a04728cf2edd744bd20c012a) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/mtd')
-rw-r--r--meta/recipes-devtools/mtd/mtd-utils_git.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-devtools/mtd/mtd-utils_git.bb b/meta/recipes-devtools/mtd/mtd-utils_git.bb
index f53c6c1122..9ffac2ed3a 100644
--- a/meta/recipes-devtools/mtd/mtd-utils_git.bb
+++ b/meta/recipes-devtools/mtd/mtd-utils_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
inherit autotools pkgconfig update-alternatives
-DEPENDS = "zlib lzo e2fsprogs util-linux"
+DEPENDS = "zlib e2fsprogs util-linux"
RDEPENDS_mtd-utils-tests += "bash"
PV = "2.0.2+${SRCPV}"
@@ -25,8 +25,9 @@ EXTRA_OECONF += "--enable-install-tests"
# xattr support creates an additional compile-time dependency on acl because
# the sys/acl.h header is needed. libacl is not needed and thus enabling xattr
# regardless whether acl is enabled or disabled in the distro should be okay.
-PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'xattr', d)}"
-PACKAGECONFIG[xattr] = ",,acl,"
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'xattr', d)} lzo"
+PACKAGECONFIG[lzo] = "--with-lzo,--without-lzo,lzo"
+PACKAGECONFIG[xattr] = "--with-xattr,--without-xattr,acl"
CPPFLAGS_append_riscv64 = " -pthread -D_REENTRANT"