aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2017-09-24 06:03:49 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-25 14:18:38 +0100
commitdbc0eaf478feb3f752ae22fd184984494fc85d0a (patch)
tree3dd1c9cfbf31fcce6d2425f9bd0ae172ebcc19f9 /meta/recipes-devtools/llvm
parent9c1ec618860404bef0348bb17efcfb5c93cc360f (diff)
downloadopenembedded-core-contrib-dbc0eaf478feb3f752ae22fd184984494fc85d0a.tar.gz
meta: drop True option to getVar calls
Search made with the following regex: getVar ?\((.*), True\). Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/llvm')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 632178fd77..f06fa49ae5 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -32,7 +32,7 @@ S = "${WORKDIR}/git"
LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install"
def get_llvm_arch(bb, d, arch_var):
import re
- a = d.getVar(arch_var, True)
+ a = d.getVar(arch_var)
if re.match('(i.86|athlon|x86.64)$', a): return 'X86'
elif re.match('arm$', a): return 'ARM'
elif re.match('armeb$', a): return 'ARM'
@@ -174,7 +174,7 @@ python llvm_populate_packages() {
split_packages = do_split_packages(d, libdir, '^lib(.*)\.so$', 'libllvm${LLVM_RELEASE}-%s', 'Split package for %s', allow_dirs=True, allow_links=True, recursive=True)
split_staticdev_packages = do_split_packages(d, libllvm_libdir, '^lib(.*)\.a$', 'libllvm${LLVM_RELEASE}-%s-staticdev', 'Split staticdev package for %s', allow_dirs=True)
if split_packages:
- pn = d.getVar('PN', True)
+ pn = d.getVar('PN')
d.appendVar('RDEPENDS_' + pn, ' '+' '.join(split_packages))
d.appendVar('RDEPENDS_' + pn + '-dbg', ' '+' '.join(split_dbg_packages))
d.appendVar('RDEPENDS_' + pn + '-staticdev', ' '+' '.join(split_staticdev_packages))