summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-03-27 23:07:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-29 08:26:27 +0000
commit1587475e45edc995b7643844594abc94160a5549 (patch)
tree5b11aa00cae6fd977874adffab02f2eb95201c48 /meta/recipes-devtools/llvm
parentf21aaefb6f082768d4bc5c55fc59a9142cfcc2d3 (diff)
downloadopenembedded-core-contrib-1587475e45edc995b7643844594abc94160a5549.tar.gz
llvm: doesn't actually need pythonnative
LLVM doesn't actually need pythonnative, the host Python2 is sufficient but cmake's executable searching currently isn't reliable in cross-compilations. Convince cmake by setting PYTHON_EXECUTABLE to point at python2 in the HOSTTOOLS directory. Note that currently LLVM *needs* python2 currently: https://github.com/llvm-mirror/llvm/blob/master/CMakeLists.txt#L670 Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/llvm')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index d2ea927651..31abadcace 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -12,7 +12,7 @@ DEPENDS = "libffi libxml2 zlib ninja-native llvm-native"
RDEPENDS_${PN}_append_class-target = " ncurses-terminfo"
-inherit perlnative pythonnative cmake pkgconfig
+inherit perlnative cmake pkgconfig
PROVIDES += "llvm${PV}"
@@ -74,6 +74,7 @@ EXTRA_OECMAKE += "-DLLVM_ENABLE_ASSERTIONS=OFF \
-DFFI_INCLUDE_DIR=$(pkg-config --variable=includedir libffi) \
-DLLVM_OPTIMIZED_TABLEGEN=ON \
-DLLVM_TARGETS_TO_BUILD='${LLVM_TARGETS}' \
+ -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python2 \
-G Ninja"
EXTRA_OECMAKE_append_class-target = "\