summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-03-28 12:35:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-29 08:28:55 +0000
commit0e7d761b1360f603a4cc0de15c67f4e182e5a6a4 (patch)
treeaac7dbcfbfb26ae7556d13a22ea14ca841d86f68 /meta/recipes-devtools/llvm
parent4405a1793a42aecd7923ab2b18df296ed8c32dc1 (diff)
downloadopenembedded-core-contrib-0e7d761b1360f603a4cc0de15c67f4e182e5a6a4.tar.gz
llvm: support older toolchains
LLVM is now warning if your host compiler is gcc <5.1, and some of our supported operating systems still only have 4.8.5. Set LLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN so those builds continue to work, hopefully we retire the old operating systems before LLVM requires 5.1+. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/llvm')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 01a7da8ebd..7832441482 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -70,6 +70,7 @@ EXTRA_OECMAKE += "-DLLVM_ENABLE_ASSERTIONS=OFF \
-DFFI_INCLUDE_DIR=$(pkg-config --variable=includedir libffi) \
-DLLVM_OPTIMIZED_TABLEGEN=ON \
-DLLVM_TARGETS_TO_BUILD='${LLVM_TARGETS}' \
+ -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON \
-DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python2 \
-G Ninja"