aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-08-17 23:24:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-23 09:25:05 +0100
commitc07f09b1b261b0d480544a6100f6a83835c62019 (patch)
tree192f19690154bf858a5d12e418a8431c90182d0b /meta/recipes-devtools/libtool
parent283a418a838ef285988a5ffc3888501ca7de63f1 (diff)
downloadopenembedded-core-contrib-c07f09b1b261b0d480544a6100f6a83835c62019.tar.gz
libtool: add bash to RDEPENDS_libtool
* Set CONFIG_SHELL="/bin/bash" * Add bash to RDEPENDS_libtool We had already set CONFIG_SHELL="/bin/bash" for libtool-native, libtool-cross and nativesdk-libtool, now also set for target libtool, if we don't set this, libtool would use /bin/sh, /bin/bash, /bin/ksh or /bin/sh5 according to the host, and the build is undetermined, this patch can fix the problem, libtool is a development tool, rdepends on bash should not cause toubles (for example, the size of the image) Have tried to set CONFIG_SHELL="/bin/sh" (/bin/sh -> dash), but there is still a few bashsim in the output libtool. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/libtool')
-rw-r--r--meta/recipes-devtools/libtool/libtool-2.4.2.inc2
-rw-r--r--meta/recipes-devtools/libtool/libtool-cross_2.4.2.bb2
-rw-r--r--meta/recipes-devtools/libtool/libtool-native_2.4.2.bb2
-rw-r--r--meta/recipes-devtools/libtool/libtool_2.4.2.bb2
-rw-r--r--meta/recipes-devtools/libtool/nativesdk-libtool_2.4.2.bb2
5 files changed, 4 insertions, 6 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-2.4.2.inc b/meta/recipes-devtools/libtool/libtool-2.4.2.inc
index 9c50d46fe2..0f1964b57b 100644
--- a/meta/recipes-devtools/libtool/libtool-2.4.2.inc
+++ b/meta/recipes-devtools/libtool/libtool-2.4.2.inc
@@ -49,3 +49,5 @@ FILES_libltdl = "${libdir}/libltdl${SOLIBS}"
FILES_libltdl-dev = "${libdir}/libltdl${SOLIBSDEV} ${includedir}"
FILES_libltdl-staticdev = "${libdir}/libltdl.a"
FILES_libltdl-dbg = "${libdir}/.debug/"
+
+export CONFIG_SHELL="/bin/bash"
diff --git a/meta/recipes-devtools/libtool/libtool-cross_2.4.2.bb b/meta/recipes-devtools/libtool/libtool-cross_2.4.2.bb
index 72fad37eaf..34aae0bf13 100644
--- a/meta/recipes-devtools/libtool/libtool-cross_2.4.2.bb
+++ b/meta/recipes-devtools/libtool/libtool-cross_2.4.2.bb
@@ -39,5 +39,3 @@ libtoolcross_sysroot_preprocess () {
}
SSTATE_SCAN_FILES += "libtoolize *-libtool"
-
-export CONFIG_SHELL="/bin/bash"
diff --git a/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb b/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
index f1051d84f3..f03859e061 100644
--- a/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
+++ b/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
@@ -21,5 +21,3 @@ do_install () {
install -d ${D}${bindir}/
install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool
}
-
-export CONFIG_SHELL="/bin/bash"
diff --git a/meta/recipes-devtools/libtool/libtool_2.4.2.bb b/meta/recipes-devtools/libtool/libtool_2.4.2.bb
index a2eb4ea437..d3f94284d4 100644
--- a/meta/recipes-devtools/libtool/libtool_2.4.2.bb
+++ b/meta/recipes-devtools/libtool/libtool_2.4.2.bb
@@ -2,6 +2,8 @@ require libtool-${PV}.inc
PR = "${INC_PR}.0"
+RDEPENDS_${PN} += "bash"
+
#
# We want the results of libtool-cross preserved - don't stage anything ourselves.
#
diff --git a/meta/recipes-devtools/libtool/nativesdk-libtool_2.4.2.bb b/meta/recipes-devtools/libtool/nativesdk-libtool_2.4.2.bb
index fff15e916d..7b5c97a97a 100644
--- a/meta/recipes-devtools/libtool/nativesdk-libtool_2.4.2.bb
+++ b/meta/recipes-devtools/libtool/nativesdk-libtool_2.4.2.bb
@@ -31,5 +31,3 @@ libtoolnativesdk_sysroot_preprocess () {
install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
install -m 755 ${D}${bindir}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${bindir_crossscripts}/${HOST_SYS}-libtool
}
-
-export CONFIG_SHELL="/bin/bash"