aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libmodulemd
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2018-11-19 16:08:05 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-20 14:08:16 +0000
commit4b53d713523f56994beb4a7b5dbb3347c8713e42 (patch)
treedc80f42e5deeda64b55901ae0880743da7289df7 /meta/recipes-devtools/libmodulemd
parenta06d53928b22d5f88276023c4d57b206db2f27f9 (diff)
downloadopenembedded-core-contrib-4b53d713523f56994beb4a7b5dbb3347c8713e42.tar.gz
libmodulemd: add a new recipe
This is a hard requirement of the new libdnf versions. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/libmodulemd')
-rw-r--r--meta/recipes-devtools/libmodulemd/libmodulemd/0001-spec_tmpl.sh-use-bin-sh-not-usr-bin-sh.patch21
-rw-r--r--meta/recipes-devtools/libmodulemd/libmodulemd/0002-modulemd-v1-meson.build-do-not-generate-gir-or-gtkdo.patch65
-rw-r--r--meta/recipes-devtools/libmodulemd/libmodulemd_git.bb21
3 files changed, 107 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libmodulemd/libmodulemd/0001-spec_tmpl.sh-use-bin-sh-not-usr-bin-sh.patch b/meta/recipes-devtools/libmodulemd/libmodulemd/0001-spec_tmpl.sh-use-bin-sh-not-usr-bin-sh.patch
new file mode 100644
index 0000000000..9465c38520
--- /dev/null
+++ b/meta/recipes-devtools/libmodulemd/libmodulemd/0001-spec_tmpl.sh-use-bin-sh-not-usr-bin-sh.patch
@@ -0,0 +1,21 @@
+From 590bd5ec9f378ab727ee404bb32f615e1bbd15bf Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Tue, 6 Nov 2018 13:41:29 +0100
+Subject: [PATCH] spec_tmpl.sh: use /bin/sh, not /usr/bin/sh
+
+Upstream-Status: Pending
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ spec_tmpl.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/spec_tmpl.sh b/spec_tmpl.sh
+index 45009c3..307c0c2 100755
+--- a/spec_tmpl.sh
++++ b/spec_tmpl.sh
+@@ -1,4 +1,4 @@
+-#!/usr/bin/sh
++#!/bin/sh
+
+ version=$1
+ template=$2
diff --git a/meta/recipes-devtools/libmodulemd/libmodulemd/0002-modulemd-v1-meson.build-do-not-generate-gir-or-gtkdo.patch b/meta/recipes-devtools/libmodulemd/libmodulemd/0002-modulemd-v1-meson.build-do-not-generate-gir-or-gtkdo.patch
new file mode 100644
index 0000000000..e94abd27c3
--- /dev/null
+++ b/meta/recipes-devtools/libmodulemd/libmodulemd/0002-modulemd-v1-meson.build-do-not-generate-gir-or-gtkdo.patch
@@ -0,0 +1,65 @@
+From b6c8039afe016d25c17cdf1b2462d6a53d49fad1 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Tue, 6 Nov 2018 13:43:00 +0100
+Subject: [PATCH] modulemd/v1/meson.build: do not generate gir or gtkdoc
+
+Both of these really need a configuration option.
+
+Upstream-Status: Inappropriate [oe-core specific]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+
+---
+ meson.build | 1 -
+ modulemd/v1/meson.build | 20 --------------------
+ 2 files changed, 21 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index db7c6a1..e0ea61a 100644
+--- a/meson.build
++++ b/meson.build
+@@ -49,7 +49,6 @@ gnome = import('gnome')
+ pkg = import('pkgconfig')
+ gobject = dependency('gobject-2.0')
+ yaml = dependency('yaml-0.1')
+-gtkdoc = dependency('gtk-doc')
+
+ spec_tmpl = find_program('spec_tmpl.sh')
+
+diff --git a/modulemd/v1/meson.build b/modulemd/v1/meson.build
+index 38e0d15..d59e519 100644
+--- a/modulemd/v1/meson.build
++++ b/modulemd/v1/meson.build
+@@ -311,19 +311,6 @@ if valgrind.found()
+ timeout : 300)
+ endif
+
+-gnome.generate_gir(
+- modulemd_v1_lib,
+- sources : modulemd_v1_srcs + modulemd_v1_hdrs,
+- nsversion : '.'.join([libmodulemd_version_array[0], '0']),
+- namespace : 'Modulemd',
+- symbol_prefix : 'modulemd_',
+- identifier_prefix : 'Modulemd',
+- includes : [
+- 'GObject-2.0',
+- ],
+- install : true,
+- )
+-
+ xcdata = configuration_data()
+ xcdata.set('VERSION', libmodulemd_version)
+ configure_file(
+@@ -339,13 +326,6 @@ configure_file(
+ configuration : cdata
+ )
+
+-gnome.gtkdoc(
+- 'modulemd-1.0',
+- install_dir: 'modulemd-1.0',
+- src_dir : './',
+- main_xml : 'modulemd-docs.xml',
+- install : true)
+-
+ pkg.generate(
+ libraries : modulemd_v1_lib,
+ subdirs : v1_header_path,
diff --git a/meta/recipes-devtools/libmodulemd/libmodulemd_git.bb b/meta/recipes-devtools/libmodulemd/libmodulemd_git.bb
new file mode 100644
index 0000000000..556478b5b7
--- /dev/null
+++ b/meta/recipes-devtools/libmodulemd/libmodulemd_git.bb
@@ -0,0 +1,21 @@
+SUMMARY = "C Library for manipulating module metadata files"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=25a3927bff3ee4f5b21bcb0ed3fcd6bb"
+
+SRC_URI = "git://github.com/fedora-modularity/libmodulemd;protocol=https \
+ file://0001-spec_tmpl.sh-use-bin-sh-not-usr-bin-sh.patch \
+ file://0002-modulemd-v1-meson.build-do-not-generate-gir-or-gtkdo.patch \
+ "
+
+PV = "1.7.0"
+SRCREV = "9af3e7b4bec2f8daaa857fa668b858e484487710"
+
+S = "${WORKDIR}/git"
+
+inherit meson
+
+EXTRA_OEMESON = "-Ddeveloper_build=false"
+
+DEPENDS += "glib-2.0 libyaml"
+
+BBCLASSEXTEND = "native"