aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libcomps/libcomps_git.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-03-10 13:23:51 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-11 16:08:50 +0000
commita47e64d985a610535449730806651f5bfd75d9ec (patch)
treeb2ba83eac2eb009f2a9e989553abd9b15cb9743f /meta/recipes-devtools/libcomps/libcomps_git.bb
parent64dd708d14f8eadb25c3b590bfdc894e2cbb246e (diff)
downloadopenembedded-core-contrib-a47e64d985a610535449730806651f5bfd75d9ec.tar.gz
libcomps: add a recipe
libcomps is required by dnf. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/libcomps/libcomps_git.bb')
-rw-r--r--meta/recipes-devtools/libcomps/libcomps_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libcomps/libcomps_git.bb b/meta/recipes-devtools/libcomps/libcomps_git.bb
new file mode 100644
index 0000000000..448ea62f67
--- /dev/null
+++ b/meta/recipes-devtools/libcomps/libcomps_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Libcomps is alternative for yum.comps library (which is for managing rpm package groups)."
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/rpm-software-management/libcomps.git \
+ file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
+ file://0002-Set-library-installation-path-correctly.patch \
+ "
+
+PV = "0.1.8+git${SRCPV}"
+SRCREV = "01a4759894cccff64d2561614a58281adf5ce859"
+
+S = "${WORKDIR}/git"
+
+inherit cmake distutils-base
+
+DEPENDS = "libxml2 expat libcheck"
+
+EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR}"
+OECMAKE_SOURCEPATH = "${S}/libcomps"
+
+BBCLASSEXTEND = "native"
+