aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/intltool/intltool_0.51.0.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-07-19 12:04:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-20 10:28:01 +0100
commit9900000d404b09a701d5368d529eb515e054e3f0 (patch)
tree7dd467260ba7bf8c866abefe7a15cfc3d3629acd /meta/recipes-devtools/intltool/intltool_0.51.0.bb
parentbf88f089c3bb8ceef7338436a1688a44399efc57 (diff)
downloadopenembedded-core-contrib-9900000d404b09a701d5368d529eb515e054e3f0.tar.gz
intltool: remove broken XML::Parser detection
intltool.m4 has a chunk of code that runs during configure which probes for a perl binary and verifies that it has the XML::Parser module. However in builds using intltool-native the perl binary that it finds is likely to not be the one that the intltool scripts will be using as the scripts hardcode nativeperl yet the m4 fragment searches for "perl" in $PATH. If the host perl doesn't have XML::Parser the configure will fail, despite the fact that the scripts will work. Solve this by taking an old patch from the upstream bug system to simply remove the check in intltool.m4 as it's generally useless, and remove existing patches that almost but not quite solved this issue. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/intltool/intltool_0.51.0.bb')
-rw-r--r--meta/recipes-devtools/intltool/intltool_0.51.0.bb21
1 files changed, 8 insertions, 13 deletions
diff --git a/meta/recipes-devtools/intltool/intltool_0.51.0.bb b/meta/recipes-devtools/intltool/intltool_0.51.0.bb
index 0a610a31f9..a7ea3b727d 100644
--- a/meta/recipes-devtools/intltool/intltool_0.51.0.bb
+++ b/meta/recipes-devtools/intltool/intltool_0.51.0.bb
@@ -6,23 +6,23 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
SRC_URI = "http://launchpad.net/${BPN}/trunk/${PV}/+download/${BP}.tar.gz \
file://intltool-nowarn.patch \
file://perl-522-deprecations.patch \
- ${NATIVEPATCHES} \
+ file://remove-perl-check.patch \
+ file://noperlcheck.patch \
"
SRC_URI[md5sum] = "12e517cac2b57a0121cda351570f1e63"
SRC_URI[sha256sum] = "67c74d94196b153b774ab9f89b2fa6c6ba79352407037c8c14d5aeb334e959cd"
-# All of the intltool scripts have the correct paths to perl already
-# embedded into them and can find perl fine, so we add the remove xml-check
-# in the intltool.m4 via the remove-xml-check.patch
-NATIVEPATCHES = "file://noperlcheck.patch \
- file://remove-xml-check.patch"
-NATIVEPATCHES_class-native = "file://use-nativeperl.patch"
-
UPSTREAM_CHECK_URI = "https://launchpad.net/intltool/trunk/"
DEPENDS = "libxml-parser-perl-native"
RDEPENDS_${PN} = "gettext-dev libxml-parser-perl"
DEPENDS_class-native = "libxml-parser-perl-native"
+
+inherit autotools pkgconfig perlnative
+
+export PERL = "${bindir}/env perl"
+PERL_class-native = "/usr/bin/env nativeperl"
+
# gettext is assumed to exist on the host
RDEPENDS_${PN}_class-native = "libxml-parser-perl-native"
RRECOMMENDS_${PN} = "perl-modules"
@@ -33,9 +33,4 @@ FILES_${PN} += "${datadir}/aclocal"
INSANE_SKIP_${PN} += "dev-deps"
-inherit autotools pkgconfig perlnative
-
-export PERL = "${bindir}/env perl"
-PERL_class-native = "/usr/bin/env nativeperl"
-
BBCLASSEXTEND = "native"