aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/guile/guile_2.0.11.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-01-11 09:27:17 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-22 23:42:53 +0000
commit31ee3460c3a0578ed36f3f5a940617ccb873c721 (patch)
treeaef5782945162bf59e9e1f474ca4b8087d153595 /meta/recipes-devtools/guile/guile_2.0.11.bb
parent8fea65047519a4d84183571e09d3f3f559d9e164 (diff)
downloadopenembedded-core-contrib-31ee3460c3a0578ed36f3f5a940617ccb873c721.tar.gz
guile: Fix build with musl
strol_l is not available on musl delete charset.alias as well its not needed Use internal gc function on musl We get errors on certain functions not being available in boeheme gc when built with musl. Therefore use the internal versions e.g. Undefined gc_set_finalizer_notifier Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/guile/guile_2.0.11.bb')
-rw-r--r--meta/recipes-devtools/guile/guile_2.0.11.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta/recipes-devtools/guile/guile_2.0.11.bb b/meta/recipes-devtools/guile/guile_2.0.11.bb
index 413c81daac..6815e257d9 100644
--- a/meta/recipes-devtools/guile/guile_2.0.11.bb
+++ b/meta/recipes-devtools/guile/guile_2.0.11.bb
@@ -24,6 +24,7 @@ SRC_URI = "${GNU_MIRROR}/guile/guile-${PV}.tar.xz \
file://libguile-Makefile.am-hook.patch \
file://libguile-VM-ASM_MUL-for-ARM-Add-earlyclobber.patch \
file://remove_strcase_l_funcs.patch \
+ file://0001-libguile-Check-for-strtol_l-during-configure.patch \
"
# file://debian/0001-Change-guile-to-guile-X.Y-for-info-pages.patch
@@ -52,6 +53,13 @@ EXTRA_OECONF_append_class-target = " --with-libunistring-prefix=${STAGING_LIBDIR
--with-libgmp-prefix=${STAGING_LIBDIR} \
--with-libltdl-prefix=${STAGING_LIBDIR}"
EXTRA_OECONF_append_libc-uclibc = " guile_cv_use_csqrt=no "
+
+CFLAGS_append_libc-musl = " -DHAVE_GC_SET_FINALIZER_NOTIFIER \
+ -DHAVE_GC_GET_HEAP_USAGE_SAFE \
+ -DHAVE_GC_GET_FREE_SPACE_DIVISOR \
+ -DHAVE_GC_SET_FINALIZE_ON_DEMAND \
+ "
+
do_configure_prepend() {
mkdir -p po
}
@@ -77,6 +85,10 @@ do_install_append_class-target() {
sed -i -e 's:${STAGING_DIR_TARGET}::g' ${D}${libdir}/pkgconfig/guile-2.0.pc
}
+do_install_append_libc-musl() {
+ rm -f ${D}${libdir}/charset.alias
+}
+
SYSROOT_PREPROCESS_FUNCS = "guile_cross_config"
guile_cross_config() {