aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-01-18 11:24:41 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-21 09:55:15 +0000
commit2d3084efdcba282388048981ee3a68672241e4df (patch)
tree75a8ab8949a3b1e441b6fa4510f7fa4f4284a375 /meta/recipes-devtools/go
parentdf61422d3852b96d084749c0b287ea074f7e48bf (diff)
downloadopenembedded-core-contrib-2d3084efdcba282388048981ee3a68672241e4df.tar.gz
go-dep: Add native and nativesdk variants
The go-dep must be used as native (and consequently as nativesdk) during the build process. This adds the two variants as supported by the recipe. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/go')
-rw-r--r--meta/recipes-devtools/go/go-dep_0.3.2.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-dep_0.3.2.bb b/meta/recipes-devtools/go/go-dep_0.3.2.bb
index 627324a1df..cdf6da1593 100644
--- a/meta/recipes-devtools/go/go-dep_0.3.2.bb
+++ b/meta/recipes-devtools/go/go-dep_0.3.2.bb
@@ -17,3 +17,5 @@ inherit go
GO_INSTALL = "${GO_IMPORT}/cmd/dep"
RDEPENDS_${PN}-dev += "bash"
+
+BBCLASSEXTEND = "native nativesdk"