summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.13.bb
diff options
context:
space:
mode:
authorAlex Kube <alexander.j.kube@gmail.com>2019-10-25 23:49:12 +0430
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-25 17:54:06 +0000
commitc1cd99c0b617717bd642ef5065c4f70ee0dfafae (patch)
tree7d6b574761110003d048dcbbb0f1db4fd5366d59 /meta/recipes-devtools/go/go_1.13.bb
parent6dd59dffd73618e4c0979b284a7968055a4eb8fb (diff)
downloadopenembedded-core-contrib-c1cd99c0b617717bd642ef5065c4f70ee0dfafae.tar.gz
go: Add go1.13 recipes
Signed-off-by: Alex Kube <alexander.j.kube@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/go/go_1.13.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.13.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go_1.13.bb b/meta/recipes-devtools/go/go_1.13.bb
new file mode 100644
index 0000000000..483e2e2cb7
--- /dev/null
+++ b/meta/recipes-devtools/go/go_1.13.bb
@@ -0,0 +1,14 @@
+require go-${PV}.inc
+require go-target.inc
+
+export GOBUILDMODE=""
+
+# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but mips
+# doesn't support -buildmode=pie, so skip the QA checking for mips and its
+# variants.
+python() {
+ if 'mips' in d.getVar('TARGET_ARCH',True):
+ d.appendVar('INSANE_SKIP_%s' % d.getVar('PN',True), " textrel")
+ else:
+ d.setVar('GOBUILDMODE', 'pie')
+}