aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-cross-canadian_1.9.bb
diff options
context:
space:
mode:
authorMatt Madison <matt@madison.systems>2018-03-04 13:09:34 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-06 06:36:33 -0800
commitcc7b179917c715b29822200fe91ecd755a5750e6 (patch)
treee270d9720007592ade5303b23f1c1480293bc123 /meta/recipes-devtools/go/go-cross-canadian_1.9.bb
parentf2ff90eb7d27a2f69f5948fa8c301de30f5c8132 (diff)
downloadopenembedded-core-contrib-cc7b179917c715b29822200fe91ecd755a5750e6.tar.gz
go: disable PIE CFLAGS for nativesdk and cross-canadian builds
The statically-linked Go code in the toolchain is not compatible with PIE, so disable its use in the C compiler during the toolchain build. Signed-off-by: Matt Madison <matt@madison.systems> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/go/go-cross-canadian_1.9.bb')
-rw-r--r--meta/recipes-devtools/go/go-cross-canadian_1.9.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/go/go-cross-canadian_1.9.bb b/meta/recipes-devtools/go/go-cross-canadian_1.9.bb
index 0306fdf684..367a967056 100644
--- a/meta/recipes-devtools/go/go-cross-canadian_1.9.bb
+++ b/meta/recipes-devtools/go/go-cross-canadian_1.9.bb
@@ -3,8 +3,8 @@ require go-${PV}.inc
export GOHOSTOS_CROSS = "${HOST_GOOS}"
export GOHOSTARCH_CROSS = "${HOST_GOARCH}"
-export CC_FOR_TARGET = "${HOST_PREFIX}gcc --sysroot=${STAGING_DIR_HOST}${SDKPATHNATIVE}"
-export CXX_FOR_TARGET = "${HOST_PREFIX}g++ --sysroot=${STAGING_DIR_HOST}${SDKPATHNATIVE}"
+export CC_FOR_TARGET = "${HOST_PREFIX}gcc --sysroot=${STAGING_DIR_HOST}${SDKPATHNATIVE} ${SECURITY_NOPIE_CFLAGS}"
+export CXX_FOR_TARGET = "${HOST_PREFIX}g++ --sysroot=${STAGING_DIR_HOST}${SDKPATHNATIVE} ${SECURITY_NOPIE_CFLAGS}"
do_compile_prepend() {
export GOBIN="${B}/bin"