summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2017-02-27 14:02:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-01 11:17:45 +0000
commit254bfb107134702d8d1e0bfbdd1b011212e8c291 (patch)
tree188ddf3ea786bc1b913904330e4f95125bd6def4 /meta/recipes-devtools/gdb
parentdec5650bc292aa3c4a0a04ace72d2cf762e9620b (diff)
downloadopenembedded-core-contrib-254bfb107134702d8d1e0bfbdd1b011212e8c291.tar.gz
recipes: Make use of the new bb.utils.filter() function
(From OE-Core rev: 0a1427bf9aeeda6bee2cc0af8da4ea5fd90aef6f) Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gdb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.12.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.12.1.bb b/meta/recipes-devtools/gdb/gdb_7.12.1.bb
index 4fddf81ffa..ea8fef122c 100644
--- a/meta/recipes-devtools/gdb/gdb_7.12.1.bb
+++ b/meta/recipes-devtools/gdb/gdb_7.12.1.bb
@@ -10,7 +10,7 @@ EXTRA_OEMAKE_append_libc-musl = "\
"
do_configure_prepend() {
- if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
+ if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
cat > ${WORKDIR}/python << EOF
#!/bin/sh
case "\$2" in