aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2015-06-22 22:12:58 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-27 22:42:51 +0100
commit612244675d8407dc183c20872b679800b745dc3b (patch)
treea043cebdac6a44375429aa21a8a8648d9006fb6b /meta/recipes-devtools/gdb
parentd2a87aa86a3eaafb696a4223c761d47cf536231d (diff)
downloadopenembedded-core-contrib-612244675d8407dc183c20872b679800b745dc3b.tar.gz
gdb: Add missing runtime dependency for python option
With python enabled, gdb refuses to start without core python modules: | Could not find platform independent libraries <prefix> | Could not find platform dependent libraries <exec_prefix> | Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>] | ImportError: No module named site It also complains if python-codecs is missing. (From OE-Core rev: 646adb4d90030970f6e2136f65b51b3c8b0c9d5c) Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gdb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.9.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.9.1.bb b/meta/recipes-devtools/gdb/gdb_7.9.1.bb
index 1abc9d8e76..cd52e27d56 100644
--- a/meta/recipes-devtools/gdb/gdb_7.9.1.bb
+++ b/meta/recipes-devtools/gdb/gdb_7.9.1.bb
@@ -4,7 +4,7 @@ require gdb-${PV}.inc
inherit python-dir
PACKAGECONFIG ??= ""
-PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python"
+PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python,python python-codecs"
PACKAGECONFIG[babeltrace] = "--with-babeltrace,--without-babeltrace,babeltrace"
do_configure_prepend() {