aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2013-05-31 10:55:46 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-04 15:53:44 +0100
commit2b47bce78536a800205b2385bba69038351545e5 (patch)
tree26253aeee1526b21e3feaac6615858d26309389d /meta/recipes-devtools/gcc
parent1f40202ce3c1282674b6cea39ef709972275f201 (diff)
downloadopenembedded-core-contrib-2b47bce78536a800205b2385bba69038351545e5.tar.gz
gcc: add build directory to include directories
Add build directory to include directories by -I${B}/include which will be searched before standard system include directories. Both libunwind and gcc supply unwind.h, once gcc use libunwind's unwind.h, the compiling will fail. This patch is generally not applicable to the upstream as they do not use libunwind. Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Jeff Polk <jeff.polk@windriver.com> Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc')
-rw-r--r--meta/recipes-devtools/gcc/gcc_4.7.bb2
-rw-r--r--meta/recipes-devtools/gcc/gcc_4.8.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/gcc/gcc_4.7.bb b/meta/recipes-devtools/gcc/gcc_4.7.bb
index 9954375e6e..f68c67a403 100644
--- a/meta/recipes-devtools/gcc/gcc_4.7.bb
+++ b/meta/recipes-devtools/gcc/gcc_4.7.bb
@@ -2,4 +2,4 @@ require recipes-devtools/gcc/gcc-${PV}.inc
require gcc-configure-target.inc
require gcc-package-target.inc
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR} -I${B}/gcc/include/ "
diff --git a/meta/recipes-devtools/gcc/gcc_4.8.bb b/meta/recipes-devtools/gcc/gcc_4.8.bb
index 9954375e6e..f68c67a403 100644
--- a/meta/recipes-devtools/gcc/gcc_4.8.bb
+++ b/meta/recipes-devtools/gcc/gcc_4.8.bb
@@ -2,4 +2,4 @@ require recipes-devtools/gcc/gcc-${PV}.inc
require gcc-configure-target.inc
require gcc-package-target.inc
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR} -I${B}/gcc/include/ "