summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc_11.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-30 14:30:18 -0700
committerKhem Raj <raj.khem@gmail.com>2021-04-28 20:44:23 -0700
commit44d3cd859200aac4668b1a3f206fca90f86501c7 (patch)
tree5ad19ef417c89a6cbe05771c58082378bd20cfcf /meta/recipes-devtools/gcc/gcc_11.1.bb
parent1432b4231db4cb5fe8fd6b498d992d5f0c9e9bdb (diff)
downloadopenembedded-core-contrib-44d3cd859200aac4668b1a3f206fca90f86501c7.tar.gz
gcc: Upgrade to GCC 11kraj/gcc11
Drop already upstream/backported patches Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc_11.1.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc_11.1.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc_11.1.bb b/meta/recipes-devtools/gcc/gcc_11.1.bb
new file mode 100644
index 0000000000..7d93590588
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc_11.1.bb
@@ -0,0 +1,14 @@
+require recipes-devtools/gcc/gcc-${PV}.inc
+require gcc-target.inc
+
+# Building with thumb enabled on armv4t armv5t fails with
+# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs
+# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
+ARM_INSTRUCTION_SET_armv4 = "arm"
+ARM_INSTRUCTION_SET_armv5 = "arm"
+
+ARMFPARCHEXT_armv6 = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
+ARMFPARCHEXT_armv7a = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
+ARMFPARCHEXT_armv7ve = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
+
+BBCLASSEXTEND = "nativesdk"