aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc-4.8
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2013-05-31 15:23:10 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-04 15:53:44 +0100
commit1f40202ce3c1282674b6cea39ef709972275f201 (patch)
treef92fe5cd048c1556ffdfed698b41c9f4af128f8c /meta/recipes-devtools/gcc/gcc-4.8
parentda5b23e45c7e4dea2f3802ff5af5c81b08aba201 (diff)
downloadopenembedded-core-contrib-1f40202ce3c1282674b6cea39ef709972275f201.tar.gz
gcc: Workaround for compiler flag mismatch
When cross compiling the target compiler, both the cross-compiler and the host compiler are used. However, the -W options used were discovered from the cross-compiler and may be incompatible with the host compiler. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-4.8')
-rw-r--r--meta/recipes-devtools/gcc/gcc-4.8/gcc-4.8-build-args.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-4.8/gcc-4.8-build-args.patch b/meta/recipes-devtools/gcc/gcc-4.8/gcc-4.8-build-args.patch
new file mode 100644
index 0000000000..95f39bb23d
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc-4.8/gcc-4.8-build-args.patch
@@ -0,0 +1,51 @@
+When cross compiling a target gcc, target flags may be used on the host
+
+Configure identifies a number of warning flags (WARN_CFLAGS and
+WARN_CXXFLAGS) from the $CC value. The cross compiler may be different
+from the host compiler and may not support the same set of flags. This
+leads to problems such as:
+
+cc1plus: error: unrecognized command line option "-Wno-narrowing"
+cc1plus: error: unrecognized command line option "-Wno-overlength-strings"
+
+Work around this problem by removing the warning flags from the
+BUILD_*FLAGS values.
+
+Upstream-Status: Pending
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+diff -ur gcc-4.8.0.orig/gcc/configure.ac gcc-4.8.0/gcc/configure.ac
+--- gcc-4.8.0.orig/gcc/configure.ac 2013-05-29 14:44:24.960853593 -0500
++++ gcc-4.8.0/gcc/configure.ac 2013-05-31 01:34:09.518775962 -0500
+@@ -1892,8 +1892,8 @@
+ # These are the normal (build=host) settings:
+ CC_FOR_BUILD='$(CC)' AC_SUBST(CC_FOR_BUILD)
+ CXX_FOR_BUILD='$(CXX)' AC_SUBST(CXX_FOR_BUILD)
+-BUILD_CFLAGS='$(ALL_CFLAGS)' AC_SUBST(BUILD_CFLAGS)
+-BUILD_CXXFLAGS='$(ALL_CXXFLAGS)' AC_SUBST(BUILD_CXXFLAGS)
++BUILD_CFLAGS='$(ALL_BUILD_CFLAGS)' AC_SUBST(BUILD_CFLAGS)
++BUILD_CXXFLAGS='$(ALL_BUILD_CXXFLAGS)' AC_SUBST(BUILD_CXXFLAGS)
+ BUILD_LDFLAGS='$(LDFLAGS)' AC_SUBST(BUILD_LDFLAGS)
+ STMP_FIXINC=stmp-fixinc AC_SUBST(STMP_FIXINC)
+
+diff -ur gcc-4.8.0.orig/gcc/Makefile.in gcc-4.8.0/gcc/Makefile.in
+--- gcc-4.8.0.orig/gcc/Makefile.in 2013-05-29 14:44:24.369853593 -0500
++++ gcc-4.8.0/gcc/Makefile.in 2013-05-31 01:34:30.360776427 -0500
+@@ -989,10 +989,16 @@
+ ALL_CFLAGS = $(T_CFLAGS) $(CFLAGS-$@) \
+ $(CFLAGS) $(INTERNAL_CFLAGS) $(COVERAGE_FLAGS) $(WARN_CFLAGS) @DEFS@
+
++ALL_BUILD_CFLAGS = $(T_CFLAGS) $(CFLAGS-$@) \
++ $(CFLAGS) $(INTERNAL_CFLAGS) @DEFS@
++
+ # The C++ version.
+ ALL_CXXFLAGS = $(T_CFLAGS) $(CFLAGS-$@) $(CXXFLAGS) $(INTERNAL_CFLAGS) \
+ $(COVERAGE_FLAGS) $(NOEXCEPTION_FLAGS) $(WARN_CXXFLAGS) @DEFS@
+
++ALL_BUILD_CXXFLAGS = $(T_CFLAGS) $(CFLAGS-$@) $(CXXFLAGS) $(INTERNAL_CFLAGS) \
++ $(NOEXCEPTION_FLAGS) @DEFS@
++
+ # Likewise. Put INCLUDES at the beginning: this way, if some autoconf macro
+ # puts -I options in CPPFLAGS, our include files in the srcdir will always
+ # win against random include files in /usr/include.