aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/expect
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2017-06-17 19:45:30 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-28 20:54:53 +0100
commitb12cdaf877bc6df71d19a6bbe8c4098d48dea269 (patch)
tree08014ee1b5e676426a12029464d012dc3c17dd83 /meta/recipes-devtools/expect
parente41c0827f54ea81274df98473e27263ef7e02c8d (diff)
downloadopenembedded-core-contrib-b12cdaf877bc6df71d19a6bbe8c4098d48dea269.tar.gz
expect: use u-a for mkpasswd
* when busybox is built with CONFIG_CRYPTPW=y, then it will provide alternative for mkpasswd, which will fail in postinst, because mkpasswd from expect wasn't using u-a: update-alternatives: Error: not linking rootfs/usr/bin/mkpasswd to /bin/busybox.nosuid since rootfs/usr/bin/mkpasswd exists and is not a link Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/expect')
-rw-r--r--meta/recipes-devtools/expect/expect_5.45.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-devtools/expect/expect_5.45.bb b/meta/recipes-devtools/expect/expect_5.45.bb
index 630f2e4649..e2d24e8d85 100644
--- a/meta/recipes-devtools/expect/expect_5.45.bb
+++ b/meta/recipes-devtools/expect/expect_5.45.bb
@@ -16,7 +16,7 @@ LIC_FILES_CHKSUM = "file://license.terms;md5=fbf2de7e9102505b1439db06fc36ce5c"
DEPENDS += "tcl"
RDEPENDS_${PN} = "tcl"
-inherit autotools
+inherit autotools update-alternatives
PR = "r1"
@@ -57,6 +57,11 @@ EXTRA_OECONF += "--with-tcl=${STAGING_LIBDIR} \
"
EXTRA_OEMAKE_install = " 'SCRIPTS=' "
+ALTERNATIVE_${PN} = "mkpasswd"
+ALTERNATIVE_LINK_NAME[mkpasswd] = "${bindir}/mkpasswd"
+# Use lower priority than busybox's mkpasswd (created when built with CONFIG_CRYPTPW)
+ALTERNATIVE_PRIORITY[mkpasswd] = "40"
+
FILES_${PN}-dev = "${libdir_native}/expect${PV}/libexpect*.so \
${includedir}/expect.h \
${includedir}/expect_tcl.h \