aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils-0.148
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-03-31 20:52:54 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-28 09:52:27 +0100
commita991226ff160c20fd7a03fe3b53b36389d3ff1f4 (patch)
tree7bcc066f23d36c2993c33f155636c07197e0aa6a /meta/recipes-devtools/elfutils/elfutils-0.148
parentaab85d9003afa544f67a9573692683f36f9e44d0 (diff)
downloadopenembedded-core-contrib-a991226ff160c20fd7a03fe3b53b36389d3ff1f4.tar.gz
elfutils_0.148.bb: Fix compilation issues on uclibc
* Add -luargp and -lintl to linker flags * __mempcpy is not there on uclibc so define it to mempcpy Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils-0.148')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils-0.148/mempcpy.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils-0.148/mempcpy.patch b/meta/recipes-devtools/elfutils/elfutils-0.148/mempcpy.patch
new file mode 100644
index 0000000000..e1e4ad0a1e
--- /dev/null
+++ b/meta/recipes-devtools/elfutils/elfutils-0.148/mempcpy.patch
@@ -0,0 +1,23 @@
+uclibc does not export __mempcpy like glibc so we alias it here.
+This patch may make sense for upstream but elfutils uses more
+glibc specific features like obstack_printf which are missing in
+uclibc they need to be fixed along to make it work all the way
+
+Upstream-status: Inappropriate[Elfutils uses more glibc specific features]
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: elfutils-0.148/libelf/elf_begin.c
+===================================================================
+--- elfutils-0.148.orig/libelf/elf_begin.c
++++ elfutils-0.148/libelf/elf_begin.c
+@@ -68,6 +68,9 @@
+ #include "libelfP.h"
+ #include "common.h"
+
++#ifdef __UCLIBC__
++#define __mempcpy mempcpy
++#endif
+
+ /* Create descriptor for archive in memory. */
+ static inline Elf *