aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2013-07-18 17:52:16 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-26 11:42:11 +0100
commit265f91149aa8c475ebe5b7069044ed94b7857fa9 (patch)
treeac4811fdcbc5f68f95d6a1c2d6d1bed536c9f899 /meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb
parent7d1e51681d25f6e6d2c20744825723ad5c83861c (diff)
downloadopenembedded-core-contrib-265f91149aa8c475ebe5b7069044ed94b7857fa9.tar.gz
e2fsprogs: add populate-extfs.sh
This script is originally from Darren Hart, it will be used for creating the ext* filesystem from a given directory, which will replace the genext2fs in image_types.bbclass at the moment, we may use the mke2fs to replace this script again when it has the initial directory support. Changes of the script: * Rename it from mkdebugfs.sh to populate-extfs.sh * Add a simple usage * Add checking for the number of the parameters * Add the "regular empty file" and "fifo" file type * Set mode, uid and gid for the file * Save the command lines to a file and batch run them * Change the error message * Improve the performance * Add the support for hardlink [YOCTO #3848] Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb')
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb
index b54c6a7685..154b864c12 100644
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb
@@ -44,6 +44,7 @@ do_install_append () {
mv ${D}${base_libdir}/e2initrd_helper ${D}${libdir}
mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
fi
+ install -m 0755 ${WORKDIR}/populate-extfs.sh ${D}${bindir}
}
RDEPENDS_e2fsprogs = "e2fsprogs-badblocks"