aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/distcc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-04-15 19:00:22 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-21 07:20:25 +0100
commit114dd78af941118c98ef2dfc4f4840ca93e8df01 (patch)
tree198337881362200e9c6a347c83103d94d9e19200 /meta/recipes-devtools/distcc
parentc94d444c79b5389dc28c6e3f2ef8c2ef2ee6f830 (diff)
downloadopenembedded-core-contrib-114dd78af941118c98ef2dfc4f4840ca93e8df01.tar.gz
distcc:Include missing fcntl.h in zeroconf
This is exposed by musl Change-Id: I39ea3a66135d33ed0a9abbd94d3c0f39120e3586 (From OE-Core rev: 02141a482e6db16968bfee787b38a284487bd770) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/distcc')
-rw-r--r--meta/recipes-devtools/distcc/distcc_3.1.bb1
-rw-r--r--meta/recipes-devtools/distcc/files/0001-zeroconf-Include-fcntl.h.patch29
2 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/distcc/distcc_3.1.bb b/meta/recipes-devtools/distcc/distcc_3.1.bb
index ad0e94f110..e4b9313d20 100644
--- a/meta/recipes-devtools/distcc/distcc_3.1.bb
+++ b/meta/recipes-devtools/distcc/distcc_3.1.bb
@@ -19,6 +19,7 @@ RRECOMMENDS_${PN} = "avahi-daemon"
SRC_URI = "http://distcc.googlecode.com/files/${BPN}-${PV}.tar.bz2 \
file://separatebuilddir.patch \
+ file://0001-zeroconf-Include-fcntl.h.patch \
file://default \
file://distccmon-gnome.desktop \
file://distcc \
diff --git a/meta/recipes-devtools/distcc/files/0001-zeroconf-Include-fcntl.h.patch b/meta/recipes-devtools/distcc/files/0001-zeroconf-Include-fcntl.h.patch
new file mode 100644
index 0000000000..b17ec9c959
--- /dev/null
+++ b/meta/recipes-devtools/distcc/files/0001-zeroconf-Include-fcntl.h.patch
@@ -0,0 +1,29 @@
+From 8331fc4759d809512f404e7a27f817ad6d616450 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 13 Apr 2015 18:00:33 -0700
+Subject: [PATCH] zeroconf: Include fcntl.h
+
+We need it for getting deinitions for O_* e.g. O_CREAT
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/zeroconf.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/zeroconf.c b/src/zeroconf.c
+index 414ddc4..31bd33f 100644
+--- a/src/zeroconf.c
++++ b/src/zeroconf.c
+@@ -33,6 +33,7 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <limits.h>
++#include <fcntl.h>
+
+ #include <avahi-common/domain.h>
+ #include <avahi-common/error.h>
+--
+2.1.4
+