aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/diffstat/diffstat_1.60.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2015-07-22 13:50:43 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-25 14:41:43 +0100
commit66bad556a9c4417f2c5aba04379e27084f26f8af (patch)
tree3abca66cca98a4e0383219dbb37858f952f2d923 /meta/recipes-devtools/diffstat/diffstat_1.60.bb
parentc9553b899eecb6ee95dd9cd0a5d586807e1af877 (diff)
downloadopenembedded-core-contrib-66bad556a9c4417f2c5aba04379e27084f26f8af.tar.gz
diffstat: upgrade to 1.60
(From OE-Core rev: 1c360d05ab39304d28936e0d2ddd815c9f96765c) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/diffstat/diffstat_1.60.bb')
-rw-r--r--meta/recipes-devtools/diffstat/diffstat_1.60.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/diffstat/diffstat_1.60.bb b/meta/recipes-devtools/diffstat/diffstat_1.60.bb
new file mode 100644
index 0000000000..29c32a8754
--- /dev/null
+++ b/meta/recipes-devtools/diffstat/diffstat_1.60.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Tool to produce a statistics based on a diff"
+DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \
+the insertions, deletions, and modifications per-file. It is useful for \
+reviewing large, complex patch files."
+HOMEPAGE = "http://invisible-island.net/diffstat/"
+SECTION = "devel"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://install-sh;endline=42;md5=b3549726c1022bee09c174c72a0ca4a5"
+
+SRC_URI = "ftp://invisible-island.net/diffstat/diffstat-${PV}.tgz \
+ file://run-ptest \
+"
+
+SRC_URI[md5sum] = "ba889da4c06b547aa2d78fa96800ae6f"
+SRC_URI[sha256sum] = "2032e418b43bae70d548e32da901ebc4ac12972381de1314bebde0b126fb0123"
+
+S = "${WORKDIR}/diffstat-${PV}"
+
+inherit autotools gettext ptest
+
+do_configure () {
+ if [ ! -e ${S}/acinclude.m4 ]; then
+ mv ${S}/aclocal.m4 ${S}/acinclude.m4
+ fi
+ autotools_do_configure
+}
+
+do_install_ptest() {
+ cp -r ${S}/testing ${D}${PTEST_PATH}
+}