aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/diffstat/diffstat_1.59.bb
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-07-16 16:52:05 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-19 00:08:49 +0100
commit0e2d98bc17d4f3b80926f9a86006010ea6907a74 (patch)
tree02810bcb15b3c9507c76c0da532a9cd0897faf3e /meta/recipes-devtools/diffstat/diffstat_1.59.bb
parenta0b408191d64804df1748163060313af31433ac8 (diff)
downloadopenembedded-core-contrib-0e2d98bc17d4f3b80926f9a86006010ea6907a74.tar.gz
diffstat: update to version 1.59
Remove unneeded patches, since they're included in new version. Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/diffstat/diffstat_1.59.bb')
-rw-r--r--meta/recipes-devtools/diffstat/diffstat_1.59.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/diffstat/diffstat_1.59.bb b/meta/recipes-devtools/diffstat/diffstat_1.59.bb
new file mode 100644
index 0000000000..f599622b3e
--- /dev/null
+++ b/meta/recipes-devtools/diffstat/diffstat_1.59.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Tool to produce a statistics based on a diff"
+DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \
+the insertions, deletions, and modifications per-file. It is useful for \
+reviewing large, complex patch files."
+HOMEPAGE = "http://invisible-island.net/diffstat/"
+SECTION = "devel"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://install-sh;endline=42;md5=b3549726c1022bee09c174c72a0ca4a5"
+
+SRC_URI = "ftp://invisible-island.net/diffstat/diffstat-${PV}.tgz \
+ file://run-ptest \
+"
+
+SRC_URI[md5sum] = "1dc7bc48ce846a0686a1af0d091ff8fb"
+SRC_URI[sha256sum] = "267d1441b8889cbefbb7ca7dfd4a17f6c8bc73bc114904c74ecad945a3dbf270"
+
+S = "${WORKDIR}/diffstat-${PV}"
+
+inherit autotools gettext ptest
+
+do_configure () {
+ if [ ! -e ${S}/acinclude.m4 ]; then
+ mv ${S}/aclocal.m4 ${S}/acinclude.m4
+ fi
+ autotools_do_configure
+}
+
+do_install_ptest() {
+ cp -r ${S}/testing ${D}${PTEST_PATH}
+}