aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/devel-config
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-03 14:45:42 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:55 -0700
commitac510cb82c007f987b481df74c7a5fede81fa85a (patch)
tree740b8af961ee6872257947dc58313a2c501e8e33 /meta/recipes-devtools/devel-config
parentc48f87a3fa9c61aaeedbcf5712a699c27d940a3b (diff)
downloadopenembedded-core-contrib-ac510cb82c007f987b481df74c7a5fede81fa85a.tar.gz
qemu-config: turn into distcc-config and a package group
* Create a new packagegroup-core-device-devel which pulls in everything that qemu-config used to, with the exception of anjuta-remote-run - this is unlikely to be widely used * Move the remainder of qemu-config to distcc-config and allow DISTCC_HOSTS to be configured via a variable of the same name * Use SUMMARY instead of DESCRIPTION for single-line description since DESCRIPTION is defaulted from SUMMARY if not set Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/devel-config')
-rw-r--r--meta/recipes-devtools/devel-config/distcc-config.bb25
-rw-r--r--meta/recipes-devtools/devel-config/distcc-config/distcc.sh4
2 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/devel-config/distcc-config.bb b/meta/recipes-devtools/devel-config/distcc-config.bb
new file mode 100644
index 0000000000..8deaa66589
--- /dev/null
+++ b/meta/recipes-devtools/devel-config/distcc-config.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Sets up distcc for compilation on the target device"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://distcc.sh"
+
+S = "${WORKDIR}"
+
+# Default to the host machine for a running qemu session
+DISTCC_HOSTS ?= "192.168.7.1"
+
+do_configure() {
+ sed -i "s%@DISTCC_HOSTS@%${DISTCC_HOSTS}%" distcc.sh
+}
+
+do_install() {
+ install -d ${D}${sysconfdir}/profile.d
+ install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
+}
+
+RDEPENDS_${PN} = "distcc"
+
+inherit allarch
diff --git a/meta/recipes-devtools/devel-config/distcc-config/distcc.sh b/meta/recipes-devtools/devel-config/distcc-config/distcc.sh
new file mode 100644
index 0000000000..b4205931dc
--- /dev/null
+++ b/meta/recipes-devtools/devel-config/distcc-config/distcc.sh
@@ -0,0 +1,4 @@
+DISTCC_HOSTS="@DISTCC_HOSTS@"
+#DISTCC_VERBOSE="1"
+
+export DISTCC_HOSTS