summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/createrepo-c/createrepo-c_0.14.3.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-07-30 17:54:30 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-31 23:02:56 +0100
commitf9ef3abfdfc5df19619328117813561e408d2147 (patch)
tree036afe78697c5143a8ef696106227644d57aa654 /meta/recipes-devtools/createrepo-c/createrepo-c_0.14.3.bb
parent3234c4e127ad28561c41ed41853adab25b731c52 (diff)
downloadopenembedded-core-contrib-f9ef3abfdfc5df19619328117813561e408d2147.tar.gz
createrepo-c: upgrade 0.14.2 -> 0.14.3
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/createrepo-c/createrepo-c_0.14.3.bb')
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c_0.14.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_0.14.3.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_0.14.3.bb
new file mode 100644
index 0000000000..22b9f3d3b1
--- /dev/null
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c_0.14.3.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "C implementation of createrepo."
+HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
+ file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
+ "
+
+SRCREV = "de9d8337885d953baae501cce75decc11d5468dd"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm libmodulemd"
+DEPENDS_append_class-native = " file-replacement-native"
+
+inherit cmake pkgconfig bash-completion distutils3-base
+
+EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF"
+
+BBCLASSEXTEND = "native nativesdk"
+
+# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
+do_install_append_class-native() {
+ create_wrapper ${D}/${bindir}/createrepo_c \
+ RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm
+}
+
+do_install_append_class-nativesdk() {
+ create_wrapper ${D}/${bindir}/createrepo_c \
+ RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm
+ rm -rf ${D}/etc
+}