summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2019-04-03 05:37:02 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-05 17:33:01 +0100
commita8397def4eebacb8876d021129309a6903b71b2f (patch)
treee1145917af4376cea92464cc9f19ec14db54a909 /meta/recipes-devtools/cmake
parentd7c0e9d1800912a0f35fb554d54945b728a04a6f (diff)
downloadopenembedded-core-contrib-a8397def4eebacb8876d021129309a6903b71b2f.tar.gz
cmake-native: Enable ccmake by default and depend on ncurses
Enable the building of the curses based ui for cmake. This depends on ncurses. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.14.1.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.14.1.bb b/meta/recipes-devtools/cmake/cmake-native_3.14.1.bb
index fedcf3d4bd..b2952ee5f5 100644
--- a/meta/recipes-devtools/cmake/cmake-native_3.14.1.bb
+++ b/meta/recipes-devtools/cmake/cmake-native_3.14.1.bb
@@ -1,7 +1,7 @@
require cmake.inc
inherit native
-DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native"
+DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native ncurses-native"
SRC_URI += "file://OEToolchainConfig.cmake \
file://environment.d-cmake.sh \
@@ -13,10 +13,9 @@ SRC_URI += "file://OEToolchainConfig.cmake \
B = "${WORKDIR}/build"
do_configure[cleandirs] = "${B}"
-# Disable ccmake since we don't depend on ncurses
CMAKE_EXTRACONF = "\
-DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
- -DBUILD_CursesDialog=0 \
+ -DBUILD_CursesDialog=1 \
-DCMAKE_USE_SYSTEM_LIBRARIES=1 \
-DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=0 \
-DCMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE=0 \