aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake
diff options
context:
space:
mode:
authorUlf Magnusson <ulfalizer@gmail.com>2016-10-01 04:47:11 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-10-03 15:46:21 +0100
commitff310dd103e16a5345a4bb48090af05f50171de3 (patch)
tree31712aea8ea2d67734c6ad8e135bfa45b90b7f25 /meta/recipes-devtools/cmake
parent5f8eb6726a492d259bfe25b0bbce2333c9505504 (diff)
downloadopenembedded-core-contrib-ff310dd103e16a5345a4bb48090af05f50171de3.tar.gz
cmake: Use bb.fatal() instead of raising FuncFailed
This sets a good example and avoids unnecessarily contributing to perceived complexity and cargo culting. Motivating quote below: < kergoth> the *original* intent was for the function/task to error via whatever appropriate means, bb.fatal, whatever, and funcfailed was what you'd catch if you were calling exec_func/exec_task. that is, it's what those functions raise, not what metadata functions should be raising < kergoth> it didn't end up being used that way < kergoth> but there's really never a reason to raise it yourself FuncFailed.__init__ takes a 'name' argument rather than a 'msg' argument, which also shows that the original purpose got lost. Signed-off-by: Ulf Magnusson <ulfalizer@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake')
-rw-r--r--meta/recipes-devtools/cmake/cmake_3.6.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/cmake/cmake_3.6.1.bb b/meta/recipes-devtools/cmake/cmake_3.6.1.bb
index 67ba9c473d..850d6de231 100644
--- a/meta/recipes-devtools/cmake/cmake_3.6.1.bb
+++ b/meta/recipes-devtools/cmake/cmake_3.6.1.bb
@@ -14,7 +14,7 @@ python () {
docdir=d.getVar("docdir", True)
if not docdir.startswith(prefix):
- raise bb.build.FuncFailed('docdir must contain prefix as its prefix')
+ bb.fatal('docdir must contain prefix as its prefix')
docdir_stripped = docdir[len(prefix):]
if len(docdir_stripped) > 0 and docdir_stripped[0] == '/':