aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake
diff options
context:
space:
mode:
authorMike Crowe <mac@mcrowe.com>2014-05-27 17:28:43 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-28 08:19:01 +0100
commite76973b4ef687c5b36ed6f9eb202322ae4af9b9f (patch)
treebf0213d66b95da29aa4a70b33379b01efd247097 /meta/recipes-devtools/cmake
parent8962fe11a0697348affb8a1ab95abca4995470a6 (diff)
downloadopenembedded-core-contrib-e76973b4ef687c5b36ed6f9eb202322ae4af9b9f.tar.gz
cmake: Avoid accidentally including libacl.h
The cmake recipe doesn't depend on libacl yet cmake will detect libacl.h and use it by default. This risks build failures if libacl.h is unstaged during the build and it also means that the build cmake will sometimes support ACLs and sometimes not. This can be avoided by setting ENABLE_ACL=0 but until the fix for http://cmake.org/Bug/view.php?id=14866 is released we also need to set HAVE_ACL_LIBACL_H=0. Signed-off-by: Mike Crowe <mac@mcrowe.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb b/meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb
index 638c074d6a..cd6b1d8845 100644
--- a/meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb
+++ b/meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb
@@ -14,4 +14,5 @@ SRC_URI[sha256sum] = "8c6574e9afabcb9fc66f463bb1f2f051958d86c85c37fccf067eb1a44a
# Disable ccmake since we don't depend on ncurses
CMAKE_EXTRACONF = "\
-DBUILD_CursesDialog=0 \
+ -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
"