aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-06-16 14:27:47 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-08 17:20:35 +0100
commitea25292bbf53c7542578e5d9f4ae0531f9d78374 (patch)
treedc9456f6aa20a25b6bdfb242aaa5d40d65656fc3 /meta/recipes-devtools/cmake/cmake
parent292a45064aa9926868c798341dc72f183c5de076 (diff)
downloadopenembedded-core-contrib-ea25292bbf53c7542578e5d9f4ae0531f9d78374.tar.gz
cmake: add nativesdk and target versions
Adds a recipe that provides the nativesdk and target versions of CMake. This recipe is based on code from OpenEmbeeded (rev b1f2e1501c19540617a829b37415c0616101c7ad). Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake')
-rw-r--r--meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch b/meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch
new file mode 100644
index 0000000000..4eb1794e4e
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake/dont-run-cross-binaries.patch
@@ -0,0 +1,22 @@
+cmake: don't run cross-binaries on host machine
+
+When doing the cross build we obviously cannot run those binaries on
+host since they can be binary incompatible.
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+
+diff -ru cmake-2.8.2.orig/CMakeLists.txt cmake-2.8.2/CMakeLists.txt
+--- cmake-2.8.2.orig/CMakeLists.txt 2010-07-28 00:48:42.000000000 +0200
++++ cmake-2.8.2/CMakeLists.txt 2010-07-28 01:05:17.000000000 +0200
+@@ -518,7 +518,8 @@
+
+ # build the remaining subdirectories
+ ADD_SUBDIRECTORY(Source)
+-ADD_SUBDIRECTORY(Utilities)
++# Come on! Running the cross-binaries on host is not a good idea.
++#ADD_SUBDIRECTORY(Utilities)
+ ADD_SUBDIRECTORY(Tests)
+
+ # add a test