aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake.inc
diff options
context:
space:
mode:
authorMike Crowe <mac@mcrowe.com>2014-04-08 14:51:22 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-08 17:44:55 +0100
commiteaf176eaabb4c558ad76512b30b28ec97fd90bc6 (patch)
tree3d6d49050abc718e3e7a7c1d06dca6b92adbb340 /meta/recipes-devtools/cmake/cmake.inc
parent9db71fa03b9d5f5307b2d09e7aa89f46f622aa09 (diff)
downloadopenembedded-core-contrib-eaf176eaabb4c558ad76512b30b28ec97fd90bc6.tar.gz
cmake: Improve method for not building ccmake
In commit 4bee0a93ed985b38c6b4eb605d8e16f5d7c82d51 I introduced an unnecessary patch to do something that can easily be done without patching. The argument to disable building ccmake can be passed to configure provided it is preceded by "--". Signed-off-by: Mike Crowe <mac@mcrowe.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake.inc')
-rw-r--r--meta/recipes-devtools/cmake/cmake.inc5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-devtools/cmake/cmake.inc b/meta/recipes-devtools/cmake/cmake.inc
index a0fcf490ec..8592a23046 100644
--- a/meta/recipes-devtools/cmake/cmake.inc
+++ b/meta/recipes-devtools/cmake/cmake.inc
@@ -43,6 +43,9 @@ do_configure_prepend() {
sed -i 's/^find_package(Qt5Widgets QUIET)/#find_package(Qt5Widgets QUIET)/g' ${S}/Source/QtDialog/CMakeLists.txt
}
+# Extra flags to pass to cmake invoked by bootstrap
+CMAKE_EXTRACONF = ""
+
do_configure () {
- ./configure --prefix=${prefix}
+ ./configure --prefix=${prefix} -- ${CMAKE_EXTRACONF}
}