aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake.inc
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-09-14 17:41:35 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-15 22:56:37 +0100
commitb8700e9fd30317d0ad583febb4e6f385284bdd51 (patch)
tree1e66dec58c9a10d80ea06feedc53427418f58b8c /meta/recipes-devtools/cmake/cmake.inc
parent0afec72913bc31d315cba079da317e8b28755ded (diff)
downloadopenembedded-core-contrib-b8700e9fd30317d0ad583febb4e6f385284bdd51.tar.gz
cmake: don't inherit autotools
cmake doesn't use autotools, the functions get replaced by either cmake.bbclass (target) or the recipe itself (native) leaving just lots of superfluous dependencies. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake.inc')
-rw-r--r--meta/recipes-devtools/cmake/cmake.inc9
1 files changed, 0 insertions, 9 deletions
diff --git a/meta/recipes-devtools/cmake/cmake.inc b/meta/recipes-devtools/cmake/cmake.inc
index 1f73b3afab..4fcb0b1ed0 100644
--- a/meta/recipes-devtools/cmake/cmake.inc
+++ b/meta/recipes-devtools/cmake/cmake.inc
@@ -21,8 +21,6 @@ SRC_URI[sha256sum] = "28ee98ec40427d41a45673847db7a905b59ce9243bb866eaf59dce0f58
UPSTREAM_CHECK_REGEX = "cmake-(?P<pver>\d+(\.\d+)+)\.tar"
-inherit autotools
-
# Ugly hack to work around undefined OE_QMAKE_PATH_EXTERNAL_HOST_BINS variable
# and possibly missing qmake binary (qtbase-native can be removed from sysroot
# e.g. in order to upgrade it, even when there is target qtbase)
@@ -45,10 +43,3 @@ do_configure_prepend() {
sed -i 's/^ find_package(Qt5Widgets REQUIRED)/# find_package(Qt5Widgets REQUIRED)/g' ${S}/Tests/QtAutogen/CMakeLists.txt
sed -i 's/^ find_package(Qt5Core REQUIRED)/# find_package(Qt5Core REQUIRED)/g' ${S}/Tests/QtAutogen/autorcc_depends/CMakeLists.txt
}
-
-# Extra flags to pass to cmake invoked by bootstrap
-CMAKE_EXTRACONF = ""
-
-do_configure () {
- ${S}/configure --prefix=${prefix} -- ${CMAKE_EXTRACONF}
-}